Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518061 - Remove 'summary' option from 'gluster vol heal..' CLI
Summary: Remove 'summary' option from 'gluster vol heal..' CLI
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: cli
Version: 3.12
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ravishankar N
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-28 05:37 UTC by Ravishankar N
Modified: 2017-12-19 07:18 UTC (History)
1 user (show)

Fixed In Version: glusterfs-glusterfs-3.12.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-19 07:18:35 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Ravishankar N 2017-11-28 05:37:20 UTC
Description of problem:
Reported by Shubhendu in https://bugzilla.redhat.com/show_bug.cgi?id=1517089#c16


commit c49fcf570439e47a5e1224436bbaf3f8dd580105 was a straight forward backport    from its corresponding master patch but in doing so, also added the 'summary'    option to the CLI. The heal info summary command is present only in      glusterfs-3.13. So remove it from the CLI in 3.12

Version-Release number of selected component (if applicable):
glusterfs-3.12.2

How reproducible:
Always.

Steps to Reproduce:
#gluster volume heal rep-vol info summary

Usage:
volume heal <VOLNAME> [enable | disable | full |statistics [heal-count [replica <HOSTNAME:BRICKNAME>]] |info [summary | split-brain] |split-brain {bigger-file <FILE> | latest-mtime <FILE> |source-brick <HOSTNAME:BRICKNAME> [<FILE>]} |granular-entry-heal {enable | disable}]

Comment 1 Worker Ant 2017-11-28 05:38:57 UTC
REVIEW: https://review.gluster.org/18871 (cli: remove summary option from heal info command) posted (#1) for review on release-3.12 by Ravishankar N

Comment 2 Worker Ant 2017-12-01 04:50:11 UTC
COMMIT: https://review.gluster.org/18871 committed in release-3.12 by \"Ravishankar N\" <ravishankar@redhat.com> with a commit message- cli: remove summary option from heal info command

commit c49fcf570439e47a5e1224436bbaf3f8dd580105 was a straight forward backport
from its corresponding master patch but in doing so, also added the 'summary'
option to the CLI. The heal info summary command is present only in
glusterfs-3.13. So remove it from the CLI in 3.12

Change-Id: Idb742f0b9752726c94619c0528fe792e4f5134fd
BUG: 1518061
Signed-off-by: Ravishankar N <ravishankar@redhat.com>
Reported-by: Shubhendu Tripathi <shtripat@redhat.com>

Comment 3 Jiffin 2017-12-19 07:18:35 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.12.4, please open a new bug report.

glusterfs-glusterfs-3.12.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-devel/2017-December/054093.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.