Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1518017 - Self Service UI does not respect some service dialog settings
Summary: Self Service UI does not respect some service dialog settings
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: API
Version: 5.8.0
Hardware: All
OS: Unspecified
high
medium
Target Milestone: GA
: 5.8.5
Assignee: eclarizi
QA Contact: Shveta
URL:
Whiteboard: ssui
Depends On:
Blocks: 1572700 1592506
TreeView+ depends on / blocked
 
Reported: 2017-11-27 22:10 UTC by Lynn Dixon
Modified: 2018-09-06 21:32 UTC (History)
19 users (show)

Fixed In Version: 5.8.4.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-23 14:17:01 UTC
Category: ---
Cloudforms Team: CFME Core


Attachments (Terms of Use)

Description Lynn Dixon 2017-11-27 22:10:19 UTC
Description of problem:
Self Service UI is not respecting certain service dialog settings, such as "load values on init" being disabled. 

Version-Release number of selected component (if applicable):
5.8.2.3.20171016155816_aaec796

How reproducible:
Create a service dialog, with a dynamic dropdown element.  Unselect the "Load Values on Init" option to disable.  

Steps to Reproduce:
1. Create service dialog with at least one dynamic drop down, click the "Show Refresh Button" option
2. De-select "Load Values on Init" to disable this option for the dynamic drop
3. Crete a catalog item that uses this service dialog
4. Navigate using the normal UI to and order the catalog item.  Notice the dynamic drop down does not run and load values, which is as expected. 
5. Now, open the Self Service ui and order this same catalog item.  Notice that the dynamic drop down will run and load values, ignoring the "load values on init" option.

Actual results:
Dyanmic Drop down is ran from the self-service UI when "load values on init" is de-selected....but does not run when ordered from the normal webui


Expected results:
Self Service UI respects all the settings of a service dialog, including the "load values on init"

Additional info:
I am working with a customer that has a very large environment, and we are leveraging a few dynamic drop downs to manage templates and networks, of which there are many.   We deslected the "load values on init" to help speed up the process of clicking and loading the catalog item, and want the user to click the refresh button when they are ready to select templates, networks, etc.  This works great from the normal WebUI, but when we try to use the self service UI it is very slow because the SSUI is trying to run all the dynamic drop downs as soon as its entered, ignoring the "load values on init" selection.

Comment 3 Lynn Dixon 2017-11-28 19:05:51 UTC
Linking customer support case to this BZ. This causing a lot of pain when trying to use a catalog item that leverages dyanmic dialogs.  Since the SSUI is not respecting the "load values on init" setting (turned off), it takes a long time before the catalog item is displayed when clicked.

Comment 6 Chris Hale 2017-12-11 20:10:52 UTC
This BZ https://bugzilla.redhat.com/show_bug.cgi?id=1514584, is necessary to be completed before we continue integration to ensure that we address this bug.

Comment 10 Chris Hale 2017-12-15 21:22:39 UTC
Fine GH PR https://github.com/ManageIQ/manageiq-ui-service/pull/1346

Comment 11 Allen W 2018-03-12 14:11:40 UTC
this got merged, moving bz to post!

Comment 13 Chris Hale 2018-05-10 20:29:32 UTC
Hi , I went and looked at this.  Where in the Classic UI do you set the load values on init.  I went looking for it in the dialog edit screen and couldn't find it.

Comment 14 Shveta 2018-05-10 21:24:42 UTC
Edit dialog "dynamic-refresh" and click on the left side on element "location"
On the right side you will see checkbox."load values on init"

Comment 15 Chris Hale 2018-05-11 19:42:35 UTC
Shveta, I went ahead and looked at the appliance and see that the API is sending back the values and it is not something the Service UI is controlling.  I think for the FINE branch it seems that there is an issue with the API not honoring the load_values_on_init setting .   Could you reassign this particular portion of the issue to someone on the API team?

Comment 16 Shveta 2018-05-17 16:27:54 UTC
Chris , I have assigned the component to API .
I guess the API team will be assigned to it now .

Comment 18 Chris Hale 2018-05-18 15:01:16 UTC
Shveta,
     Could you please create an appliance to reproduce this issue on the FINE branch and mark this appliance to not auto destruct. I am looking into it with some fellow team members and we wanted an appliance to validate against.

Comment 20 Shveta 2018-05-18 17:19:29 UTC
Appliance : https://10.8.198.6.

Comment 21 Joe Vlcek 2018-05-21 17:26:59 UTC
Shveta,

Can you please confirm this functionality is only failing on the "Fine" branch and
is working correctly on releases newer than "Fine"?

The suspected cause for this not working on the "Fine" branch is because the "Fine"
branch is missing these 2 PRs [1]

Simply cheery picking these 2 PRs to the "Fine" branch is not straight forward and
could induce other issues.

Thank you. JoeV

[1] 
  - https://github.com/ManageIQ/manageiq/pull/17329
  - https://github.com/ManageIQ/manageiq/pull/17436

Comment 22 Joe Vlcek 2018-05-21 17:26:59 UTC
Shveta,

Can you please confirm this functionality is only failing on the "Fine" branch and
is working correctly on releases newer than "Fine"?

The suspected cause for this not working on the "Fine" branch is because the "Fine"
branch is missing these 2 PRs [1]

Simply cheery picking these 2 PRs to the "Fine" branch is not straight forward and
could induce other issues.

Thank you. JoeV

[1] 
  - https://github.com/ManageIQ/manageiq/pull/17329
  - https://github.com/ManageIQ/manageiq/pull/17436

Comment 23 Dave Johnson 2018-05-21 19:29:04 UTC
Shveta, see comment 21/22 please.

Comment 24 Shveta 2018-05-21 20:26:54 UTC
Yes this works in 5.9.2.4.20180501195858_35dc609.

Comment 25 Tina Fitzgerald 2018-05-22 13:56:50 UTC
Per Brad, this needs to be fixed in 5.8.

Comment 26 Shveta 2018-05-29 20:45:12 UTC
Fixed in master.20180525014609_98ef65d


Note You need to log in before you can comment on or make changes to this bug.