Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517974 - [AAA] Locale selector on welcome page doesn't work when using http
Summary: [AAA] Locale selector on welcome page doesn't work when using http
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: AAA
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
low
low vote
Target Milestone: ovirt-4.2.0
: 4.2.0
Assignee: Ravi Nori
QA Contact: Gonza
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-27 19:40 UTC by Greg Sheremeta
Modified: 2017-12-22 06:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-22 06:50:43 UTC
oVirt Team: Infra
rule-engine: ovirt-4.2+


Attachments (Terms of Use)
console network log (deleted)
2017-11-27 19:40 UTC, Greg Sheremeta
no flags Details
engine debug log (deleted)
2017-11-27 19:41 UTC, Greg Sheremeta
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 84824 master MERGED engine : Locale selector on welcome page doesn't work 2017-12-07 09:22:56 UTC

Description Greg Sheremeta 2017-11-27 19:40:09 UTC
Description of problem:
Locale selector on welcome page doesn't work

Version-Release number of selected component (if applicable):
4.2 master, a065271

How reproducible:
always, even when logged in

Steps to Reproduce:
1. go to welcome page
(optional -- login -- it's broken both when logged in and out)
2. use select box to change locale

Actual results:
page redirects and stays on English

Expected results:
Select box should keep newly selected locale, and welcome page should render in selected locale

Additional info:
see attachments, network log and engine debug log

Comment 1 Red Hat Bugzilla Rules Engine 2017-11-27 19:40:16 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 2 Greg Sheremeta 2017-11-27 19:40:58 UTC
Created attachment 1359596 [details]
console network log

Comment 3 Greg Sheremeta 2017-11-27 19:41:21 UTC
Created attachment 1359597 [details]
engine debug log

Comment 4 Greg Sheremeta 2017-11-27 20:33:17 UTC
Ravi noticed that this is only an issue with http, and https works fine. Lowering.

Comment 5 Martin Perina 2017-11-28 10:02:51 UTC
(In reply to Greg Sheremeta from comment #4)
> Ravi noticed that this is only an issue with http, and https works fine.
> Lowering.

Home page is available over HTTP only in development environment. If RPM installation is used, HTTPS is enforced, so there should not be any way how to access this page using HTTP.

Due to above moving to 4.3, if it's some easy fix we can backport otherwise I'd close it as WONTFIX.

Comment 6 Sandro Bonazzola 2017-12-12 16:06:05 UTC
This bug is targeted 4.2.1 but is modified in 4.2.0.
Can you please check / verify this bug status and set target milestone and bug status accordingly?

Comment 7 Martin Perina 2017-12-12 18:20:13 UTC
Moving to 4.2.0 as the fix is part of latest build

Comment 8 Gonza 2017-12-21 10:17:37 UTC
Verified with:
ovirt-engine-4.2.0.2-0.1.el7.noarch

Comment 9 Sandro Bonazzola 2017-12-22 06:50:43 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.