Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517961 - Failure of some regression tests on Centos7 (passes on centos6)
Summary: Failure of some regression tests on Centos7 (passes on centos6)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: mainline
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-27 18:18 UTC by Amar Tumballi
Modified: 2018-03-15 11:22 UTC (History)
1 user (show)

Fixed In Version: glusterfs-4.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-15 11:22:12 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Amar Tumballi 2017-11-27 18:18:40 UTC
Description of problem:
Below tests pass on centos6 but are failing on centos7.

./tests/bugs/cli/bug-1169302.t
./tests/bugs/posix/bug-990028.t
./tests/bugs/glusterd/bug-1260185-donot-allow-detach-commit-unnecessarily.t
./tests/bugs/core/multiplex-limit-issue-151.t
./tests/basic/afr/split-brain-favorite-child-policy.t
./tests/bugs/core/bug-1432542-mpx-restart-crash.t

Version-Release number of selected component (if applicable):
master (as of Nov 27th 2017)

How reproducible:
~100%

Expected results:
None of this should fail.

Comment 1 Amar Tumballi 2017-11-27 18:19:38 UTC
Current recommendation from developers is to mark these tests as KNOWN ISSUE with this bug-id, and work on this in background.

Comment 2 Worker Ant 2017-11-27 18:29:35 UTC
REVIEW: https://review.gluster.org/18870 (tests: mark currently failing regression tests as known issues) posted (#1) for review on master by Amar Tumballi

Comment 3 Worker Ant 2017-11-28 06:21:23 UTC
REVIEW: https://review.gluster.org/18873 (tests: fix bug-1432542-mpx-restart-crash.t spurious failure) posted (#1) for review on master by Atin Mukherjee

Comment 4 Worker Ant 2017-11-28 09:44:44 UTC
COMMIT: https://review.gluster.org/18873 committed in master by \"Atin Mukherjee\" <amukherj@redhat.com> with a commit message- tests: fix bug-1432542-mpx-restart-crash.t spurious failure

Change-Id: Ied1215bfec0ccf2ec8ee55a0aaf618517b67bd55
BUG: 1517961
Signed-off-by: Atin Mukherjee <amukherj@redhat.com>

Comment 5 Worker Ant 2017-11-28 13:05:13 UTC
COMMIT: https://review.gluster.org/18870 committed in master by \"Amar Tumballi\" <amarts@redhat.com> with a commit message- tests: mark currently failing regression tests as known issues

Change-Id: If6c36dc6c395730dfb17b5b4df6f24629d904926
BUG: 1517961
Signed-off-by: Amar Tumballi <amarts@redhat.com>

Comment 6 Worker Ant 2017-11-29 05:56:01 UTC
REVIEW: https://review.gluster.org/18881 (tests: fix for bug-1260185-donot-allow-detach-commit-unnecessarily.t failure) posted (#1) for review on master by hari gowtham

Comment 7 Worker Ant 2017-11-29 07:18:17 UTC
REVIEW: https://review.gluster.org/18884 (tests: Renable basic/afr/split-brain-favorite-child-policy.t) posted (#1) for review on master by Nigel Babu

Comment 8 Worker Ant 2017-11-29 08:52:01 UTC
COMMIT: https://review.gluster.org/18884 committed in master by \"Nigel Babu\" <nigelb@redhat.com> with a commit message- tests: Renable basic/afr/split-brain-favorite-child-policy.t

This test was failing due to an infra issue. The infra issue is now
fixed.

BUG: 1517961
Change-Id: I09dfab9c0a3ebe73c738222e6269d9e35c85eddb
Signed-off-by: Nigel Babu <nigelb@redhat.com>

Comment 9 Worker Ant 2017-11-29 10:15:11 UTC
REVIEW: https://review.gluster.org/18889 (tests: fix bug-1432542-mpx-restart-crash.t failure) posted (#1) for review on master by Atin Mukherjee

Comment 10 Worker Ant 2017-11-29 10:47:50 UTC
REVIEW: https://review.gluster.org/18881 (tests: fix for bug-1260185-donot-allow-detach-commit-unnecessarily.t failure) posted (#4) for review on master by hari gowtham

Comment 11 Worker Ant 2017-11-30 10:16:00 UTC
COMMIT: https://review.gluster.org/18881 committed in master by \"hari gowtham\" <hari.gowtham005@gmail.com> with a commit message- tests: fix for bug-1260185-donot-allow-detach-commit-unnecessarily.t failure

problem: detach commit was issues before detach start was completed.

fix: wait for detach start to finish and then detach commit.

Change-Id: I639962be6de6dbd1512f0a5617050d1e6872eac8
BUG: 1517961
Signed-off-by: hari gowtham <hgowtham@redhat.com>

Comment 12 Worker Ant 2017-12-01 04:37:43 UTC
REVIEW: https://review.gluster.org/18893 (tests: Fix a broken test case) posted (#3) for review on master by Poornima G

Comment 13 Worker Ant 2017-12-01 05:00:19 UTC
COMMIT: https://review.gluster.org/18893 committed in master by \"Poornima G\" <pgurusid@redhat.com> with a commit message- tests: Fix a broken test case

Issue: When using statedump command to take statedump of the
gfapi process, we specify the following things:

$gluster volume statedump <volname> client <host>:<pid>
   pid: Pid of the gfapi application
   host: This should be the IP/hostname as seen by the glusterd,
         the gfapi application is connected to.

In this test case, if gfapi application is running locally,
and is connected to $H1 glusterd, the <host> need not be $H1.
<host> could be localhost, 127.0.0.1, 127.1.1.1 etc. based on
the configuration of the system. Hence use netstat to find the
right <host> value.

Change-Id: I6efb9d1ccaf9c6841a9ab7c9ebfecafc03c0bc5e
BUG: 1517961
Signed-off-by: Poornima G <pgurusid@redhat.com>

Comment 14 Worker Ant 2017-12-01 13:43:24 UTC
REVIEW: https://review.gluster.org/18909 (run-tests.sh: provide retry count option) posted (#2) for review on master by Amar Tumballi

Comment 15 Worker Ant 2017-12-05 14:23:24 UTC
COMMIT: https://review.gluster.org/18909 committed in master by \"Amar Tumballi\" <amarts@redhat.com> with a commit message- run-tests.sh: provide retry count option

and default it to 5.

With this change, if any test fails due to timing issues (because of
slower/faster VM etc), there is a retry logic which gets triggered.
Many times, if a test successfully fails more than 5 times, there may
be a genuine issue with it, one should take a serious look at the
failing test.

Change-Id: Ia88e3293fd2724b0f9f09d8bc026560792fc1578
BUG: 1517961
Signed-off-by: Amar Tumballi <amarts@redhat.com>

Comment 16 Shyamsundar 2018-03-15 11:22:12 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-4.0.0, please open a new bug report.

glusterfs-4.0.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-March/000092.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.