Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517938 - [REGRESSION] Production settings are not being honored
Summary: [REGRESSION] Production settings are not being honored
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: 5.10.0
Assignee: Jason Frey
QA Contact: Dave Johnson
URL:
Whiteboard: regression:amazon:azure
Depends On:
Blocks: 1518290
TreeView+ depends on / blocked
 
Reported: 2017-11-27 17:45 UTC by Leo Khomenko
Modified: 2018-06-21 20:35 UTC (History)
8 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1518290 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:35:35 UTC
Category: Bug
Cloudforms Team: Azure


Attachments (Terms of Use)

Comment 4 Jason Frey 2017-11-27 21:07:53 UTC
This seems like a bigger problem in that none of the production settings are being honored at all.

Comment 5 Jason Frey 2017-11-27 21:19:13 UTC
I think I know what the problem is.

https://github.com/ManageIQ/manageiq-providers-azure/blob/master/config/settings.yml#L32  contains an empty Array as the default, and the production.yml override is being evaluated at a lower precedence for some reason.

Comment 7 CFME Bot 2017-11-28 14:16:50 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/63759e4176421b7189af7fe7aa1c83e60f322a81

commit 63759e4176421b7189af7fe7aa1c83e60f322a81
Author:     Jason Frey <jfrey@redhat.com>
AuthorDate: Mon Nov 27 18:07:12 2017 -0500
Commit:     Jason Frey <jfrey@redhat.com>
CommitDate: Mon Nov 27 18:11:10 2017 -0500

    Fix issue where plugin settings had higher precedence than manageiq
    
    One of the side effects of this is that in production deployments with
    overrides, the overrides were being clobbered by the plugins.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1517938

 lib/vmdb/settings.rb | 16 +++++++---------
 1 file changed, 7 insertions(+), 9 deletions(-)


Note You need to log in before you can comment on or make changes to this bug.