Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517928 - RFE: provide separate images for all supported OpenJDK versions
Summary: RFE: provide separate images for all supported OpenJDK versions
Keywords:
Status: NEW
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Docker
Version: TBD EAP 6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: John Doyle
QA Contact: Michal Karm Babacek
eap-docs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-27 17:29 UTC by François Cami
Modified: 2018-06-28 15:18 UTC (History)
9 users (show)

Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)

Description François Cami 2017-11-27 17:29:44 UTC
As per: 
https://access.redhat.com/articles/111663
we support EAP6 with OpenJDK 1.6 / 1.7 / 1.8.

As per:
https://access.redhat.com/articles/1299013
RHEL currently supports OpenJDK 1.7 / 1.8.

We only ship an image with the latest OpenJDK with JBoss (https://bugzilla.redhat.com/show_bug.cgi?id=1506146).

Would it be possible to ship images for all supported JDKs at any point in time (so currently two images)?

Comment 3 John Doyle 2018-06-27 17:14:54 UTC
I'm not sure what the precise request is. Are you asking that we provide options to the user like:

EAP 6 on OpenJDK 8
EAP 6 on OpenJDK 7
EAP 7 on OpenJDK 8
EAP 7 on OpenJDK 11

And these options are continuously maintained for the lifecycle of EAP and OpenJDK?

Can you describe the change in workflow that and update of EAP 7 to OpenJDK 11 would impose on a customer. In my experience, most customers are not overly concerned with the JVM version when deploying the containers we ship.


Note You need to log in before you can comment on or make changes to this bug.