Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517860 - [RFE] Tool - Ceph OSD debug log parser to assist with inconsistent objects
Summary: [RFE] Tool - Ceph OSD debug log parser to assist with inconsistent objects
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS
Version: 3.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: 3.*
Assignee: Josh Durgin
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-27 15:41 UTC by Mike Hackett
Modified: 2019-03-07 22:58 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-07 22:57:32 UTC


Attachments (Terms of Use)

Description Mike Hackett 2017-11-27 15:41:25 UTC
Description of problem:
Inconsistent objects face the same root cause issues as incomplete PG’s, the debug logs are generally cryptic when attempting to determine cause for the inconsistent objects. Determining which OSD has the missing object and finding the OSD with the last version of that object is difficult.

Incomplete PG tool RFE: https://bugzilla.redhat.com/show_bug.cgi?id=1442881


Additions if needed:

Tool to parse OSD debug logs to assist with determining recovery scenarios.

Comment 3 Neha Ojha 2019-03-07 22:57:32 UTC
We have list-inconsistent-pg, which can be used for this purpose now.

More info: http://docs.ceph.com/docs/luminous/rados/troubleshooting/troubleshooting-pg/#pgs-inconsistent

Comment 4 Greg Farnum 2019-03-07 22:58:20 UTC
And also list-inconsistent-obj, which gives you the details of any inconsistent objects (and all the replicas) within a PG.


Note You need to log in before you can comment on or make changes to this bug.