Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517857 - Brick process refuses to start and prints "Invalid port identifier" error message
Summary: Brick process refuses to start and prints "Invalid port identifier" error mes...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs
Version: rhgs-3.2
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Gaurav Yadav
QA Contact: Bala Konda Reddy M
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-27 15:31 UTC by Damian Wojsław
Modified: 2017-11-27 16:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-27 16:46:31 UTC


Attachments (Terms of Use)

Description Damian Wojsław 2017-11-27 15:31:12 UTC
Description of problem:
During the start of volume brick process tries to get TCP port assigned for communication. On the node wide range of ports is reserved though /proc/sys/net/ipv4/ip_local_reserved_ports 
The brick tries lots of ports and all of them are reserved in this file. After some time the brick init runs out of ports to assign and the start volume fails. 
There is however one issue I don't understand. The brick process start printing XXXX is not a valid port identifier well under GF_PORT_MAX 65535. I don't understand the source code well enough to provide the Customer with an answer why assigning a port fails before we reach 65535

Version-Release number of selected component (if applicable):
glusterfs-3.8.4-18.el7rhgs.x86_64                           Thu Nov 16 11:05:08 2017
glusterfs-api-3.8.4-18.el7rhgs.x86_64                       Thu Nov 16 11:05:08 2017
glusterfs-cli-3.8.4-18.el7rhgs.x86_64                       Thu Nov 16 11:05:09 2017
glusterfs-client-xlators-3.8.4-18.el7rhgs.x86_64            Thu Nov 16 11:05:08 2017
glusterfs-fuse-3.8.4-18.el7rhgs.x86_64                      Thu Nov 16 11:05:09 2017
glusterfs-libs-3.8.4-18.el7rhgs.x86_64                      Thu Nov 16 11:05:07 2017
glusterfs-server-3.8.4-18.el7rhgs.x86_64                    Thu Nov 16 11:59:28 2017

How reproducible:
Each time the ports are reserved in /proc/ 

Steps to Reproduce:
1. Propagate /proc/sys/net/ipv4/ip_local_reserved_ports  with ports from 395 to 56881
2. Create volume
3. Start volume

Actual results:
Brick process won't stop due to lack of free port to assign

Expected results:
If there are ports under 65535 available brick process should start. 

Additional info:
In further comments


Note You need to log in before you can comment on or make changes to this bug.