Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517839 - stale cpu frequency in /proc/cpuinfo
Summary: stale cpu frequency in /proc/cpuinfo
Keywords:
Status: CLOSED DUPLICATE of bug 1511701
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-27 15:07 UTC by Dalibor Pospíšil
Modified: 2017-11-27 17:48 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-27 17:48:29 UTC


Attachments (Terms of Use)

Description Dalibor Pospíšil 2017-11-27 15:07:46 UTC
Description of problem:
CPU frequency in /proc/cpuinfo is not the actual one. The is regression against kernel-4.13.12-200.fc26.x86_64

Version-Release number of selected component (if applicable):
kernel-4.13.13-200.fc26.x86_64
kernel-4.13.13-300.fc27.x86_64


How reproducible:
100%

Steps to Reproduce:
1. grep 'cpu MHz' /proc/cpuinfo
2. cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq 
3.

Actual results:
the first gives stale numbers
while the second reflect reality

Expected results:
both should correspond

Comment 1 Dalibor Pospíšil 2017-11-27 15:51:16 UTC
I had this issue also prior the kernel-4.13.12-200.fc26.x86_64 on few kernels, this was somehow fixed in kernel-4.13.12-200.fc26.x86_64 and broken again in kernel-4.13.13-200.fc26.x86_64

Comment 2 Jeremy Cline 2017-11-27 17:48:29 UTC
Hello,

Thank you for the bug report. This is a known issue. A fix landed in 4.13.12, but was reverted for 4.14 and 4.13.13 as it performs poorly on systems with many cores. A new fix is being worked on.

*** This bug has been marked as a duplicate of bug 1511701 ***


Note You need to log in before you can comment on or make changes to this bug.