Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517819 - no warning when trying to upgrade a host with non-migratable VMs
Summary: no warning when trying to upgrade a host with non-migratable VMs
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ---
: ---
Assignee: bugs@ovirt.org
QA Contact: Pavol Brilla
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-27 14:28 UTC by Evgheni Dereveanchin
Modified: 2018-04-27 10:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-27 10:03:09 UTC
oVirt Team: Infra


Attachments (Terms of Use)

Description Evgheni Dereveanchin 2017-11-27 14:28:15 UTC
Description of problem:
 The "Installation -> upgrade" button in the hosts tab of the Admin portal does not produce a warning when non-migratable VMs are running on the host.

Version-Release number of selected component (if applicable):
 ovirt-engine-4.2.0-0.0.master.20171124105728.gitb8ce373.el7.centos

How reproducible:
 Always

Steps to Reproduce:
1. Create a High Performance VM and start it on a random host
2. select this host in the admin portal and press Installation -> upgrade
3. press OK on the modal window

Actual results:
 Upgrade never happens since the VM is non-migrateable so the host can't be evacuated

Expected results:
 Warning shown, saying that the host runs non-migrateable VMs and can't be upgraded


Additional info:
 To see such a warning, click on "Management -> Maintenance" in the Admin portal for the same host. We should have the same result for upgrades as well.

Comment 1 Martin Perina 2018-04-27 10:03:09 UTC
As we have recently made flow "Move host to Maintenance" asynchronous (BZ1507473), we no longer display validation warnings within a dialog, but only in Events. So we want to be aligned also in "Upgrade host" flow, which is also asynchronous and moving host to Maintenance is part of it.


Note You need to log in before you can comment on or make changes to this bug.