Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517818 - Missing kdump finished message in events
Summary: Missing kdump finished message in events
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Infra
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-4.2.2
: ---
Assignee: Ravi Nori
QA Contact: Pavol Brilla
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-27 14:27 UTC by Petr Matyáš
Modified: 2018-06-05 15:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-29 11:02:26 UTC
oVirt Team: Infra
rule-engine: ovirt-4.2+
rule-engine: blocker+


Attachments (Terms of Use)
engine log (deleted)
2017-11-27 14:27 UTC, Petr Matyáš
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 88748 master MERGED engine : Missing kdump finished message in events 2018-03-20 10:53:35 UTC
oVirt gerrit 89235 ovirt-engine-4.2 MERGED engine : Missing kdump finished message in events 2018-03-20 11:53:59 UTC
Red Hat Bugzilla 1586161 None None None Never

Internal Links: 1586161

Description Petr Matyáš 2017-11-27 14:27:27 UTC
Created attachment 1359491 [details]
engine log

Description of problem:
When host is kdumping I get 'Kdump flow is in progress on host $host' event, but I never get 'Kdump flow finished on host $host' event.

Version-Release number of selected component (if applicable):
ovirt-engine-4.2.0-0.5.master.el7.noarch
vdsm-4.20.8-1.el7ev.x86_64

How reproducible:
always

Steps to Reproduce:
1. add PM to a host
2. get that host to execute kdump (echo c > /proc/sysrq-trigger)
3.

Actual results:
host is in kdumping status for a while, kdump in progres is printed but kdump finished is not

Expected results:
there is kdump finished message in events

Additional info:

Comment 1 Red Hat Bugzilla Rules Engine 2017-11-28 10:03:13 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 2 Petr Matyáš 2018-01-25 16:20:06 UTC
With ovirt-engine-4.2.1.3-0.1.el7.noarch there is no kdump in progress (this message was visible before) nor kdump finished messages.

I have vdsm-4.20.17-1.el7ev.x86_64 on the host.

Comment 4 Pavol Brilla 2018-03-26 11:10:19 UTC
Verified on 	4.2.2.5-0.1.el7:


Mar 26, 2018, 1:05:45 PM
Kdump flow finished on host host_mixed_3.

Mar 26, 2018, 1:04:40 PM
Auto fence for host host_mixed_3 was started.

Mar 26, 2018, 1:04:40 PM
Kdump flow is in progress on host host_mixed_3.

Comment 5 Sandro Bonazzola 2018-03-29 11:02:26 UTC
This bugzilla is included in oVirt 4.2.2 release, published on March 28th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.2 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.