Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517810 - Adding additional ha-host fails.
Summary: Adding additional ha-host fails.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Host-Deploy
Version: 4.2.0
Hardware: x86_64
OS: Linux
urgent
urgent vote
Target Milestone: ovirt-4.2.0
: 4.2.0
Assignee: Simone Tiraboschi
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks: 1451653 1455169
TreeView+ depends on / blocked
 
Reported: 2017-11-27 14:06 UTC by Nikolai Sednev
Modified: 2017-12-20 11:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-12-20 11:29:08 UTC
oVirt Team: Integration
rule-engine: ovirt-4.2+
rule-engine: blocker+
ylavi: planning_ack+
sbonazzo: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)
logs from failed host alma03 (deleted)
2017-11-27 14:15 UTC, Nikolai Sednev
no flags Details
logs from alma04 (deleted)
2017-11-27 14:16 UTC, Nikolai Sednev
no flags Details
logs from the engine (deleted)
2017-11-27 14:18 UTC, Nikolai Sednev
no flags Details
hostdeploy logs from engine (deleted)
2017-11-27 14:22 UTC, Nikolai Sednev
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 84720 master MERGED ansible: fix configuration disk description 2018-09-03 09:37:40 UTC
oVirt gerrit 84823 master ABANDONED HostedEngine: fix config disk detection 2017-11-29 13:22:27 UTC
oVirt gerrit 84863 master MERGED HE: Use hidden config option to identify HE config volume 2017-11-30 11:56:32 UTC

Description Nikolai Sednev 2017-11-27 14:06:42 UTC
Description of problem:
Forth to our conversation with Simone, I'm opening this bug due to failed addition of ha-host to SHE environment, deployed using --ansible, over Gluster storage.


Version-Release number of selected component (if applicable):
ovirt-hosted-engine-ha-2.2.0-0.0.master.20171122155227.20171122155225.gitbc3ec09.el7.centos.noarch
ovirt-hosted-engine-setup-2.2.0-0.0.master.20171124110627.gitc5547b6.el7.centos.noarch
ovirt-engine-appliance-4.2-20171125.1.el7.centos.noarch

How reproducible:
100%

Steps to Reproduce:
1.Deploy SHE over gluster storage.
2.Don't add additional storage domains.
3.Add additional ha-host using UI.

Actual results:
Host being added, but as regular host only, instead of being added as ha-host.
Host shown without crown symbol and in CLI shown as "alma03 ~]# hosted-engine --vm-status
You must run deploy first"

Expected results:
Host should be added as ha-host, once chosen as such during addition process.

Additional info:
Sosreports from all hosts and engine attached.

Comment 1 Nikolai Sednev 2017-11-27 14:15:31 UTC
Created attachment 1359474 [details]
logs from failed host alma03

Comment 2 Nikolai Sednev 2017-11-27 14:16:23 UTC
Created attachment 1359475 [details]
logs from alma04

Comment 3 Nikolai Sednev 2017-11-27 14:18:57 UTC
Created attachment 1359488 [details]
logs from the engine

Comment 4 Nikolai Sednev 2017-11-27 14:22:10 UTC
Created attachment 1359490 [details]
hostdeploy logs from engine

Comment 5 Martin Sivák 2017-11-27 14:41:32 UTC
This is not a regression! Node 0 way of deployment was never released yet, the old flow still works well I presume. Meaning this is "just" a bug in RFE for as long as Node 0 is not the default deployment method for 4.2.0 (which it is not).

Please do not link Node 0 issues to general hosted engine bugs that have nothing to do with deployment.

Comment 6 Sandro Bonazzola 2017-11-27 15:31:11 UTC
Dropping regression keyword and blocker flag according to comment #5

Comment 7 Martin Sivák 2017-11-29 12:33:24 UTC
This is not a regression although it might very well be a blocker as we want to have Node 0 in (as alternative) for testing.

Comment 8 Nikolai Sednev 2017-12-11 12:51:43 UTC
Works fine on clean --ansible SHE deployment over RHEL7.4, using ovirt-hosted-engine-setup-2.2.1-0.0.master.20171206172737.gitd3001c8.el7.centos.noarch and ovirt-engine-appliance-4.2-20171210.1.el7.centos.noarch.
Moving to verified.

Comment 9 Sandro Bonazzola 2017-12-20 11:29:08 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.