Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517754 - [RFE][heat] Option to specify Timeout during Overcloud Node Delete
Summary: [RFE][heat] Option to specify Timeout during Overcloud Node Delete
Keywords:
Status: CLOSED DUPLICATE of bug 1499020
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: RHOS Maint
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-27 11:53 UTC by Nikhil Shetty
Modified: 2017-12-12 18:01 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-12 18:01:01 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 522863 None None None 2017-11-29 05:29:58 UTC
OpenStack gerrit 523326 None None None 2017-11-29 04:26:37 UTC

Description Nikhil Shetty 2017-11-27 11:53:56 UTC
Description of problem: WE would like to Request For Allowing an option to Specify "Timeout" during Overcloud Node Delete 


Version-Release number of selected component (if applicable): All Versions


How reproducible: During Performing the following Action 
"Openstack overcloud Node delete" or "heat overcloud node-delete" we cannot find an option to specify timeout in case the Action gets stuck/hang. following is the Specific Command for which we need Timeout.

~~~
openstack overcloud node delete 
--stack <Stack ID>
--templates -e Templates...



Steps to Reproduce:NA
1.
2.
3.

Actual results: We donot have any value for timeout


Expected results:We should have an option like "--timeout" during Node Deletion

Comment 1 Rabi Mishra 2017-11-28 07:49:11 UTC
It seems scale_down/delete_node workflow has 'timeout' input[1], we probably  just have to add it to cli, if it's useful.

[1] http://git.openstack.org/cgit/openstack/python-tripleoclient/tree/tripleoclient/workflows/scale.py#n54

Comment 2 Brad P. Crochet 2017-12-12 18:01:01 UTC

*** This bug has been marked as a duplicate of bug 1499020 ***


Note You need to log in before you can comment on or make changes to this bug.