Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517748 - Clementine doesn't work on Fedora 27, 28
Summary: Clementine doesn't work on Fedora 27, 28
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: clementine
Version: 28
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Jan Grulich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1519618 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-27 11:39 UTC by Toni
Modified: 2018-10-30 17:20 UTC (History)
9 users (show)

Fixed In Version: clementine-1.3.1-28.fc28 clementine-1.3.1-28.fc27 clementine-1.3.1-28.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-16 11:38:23 UTC


Attachments (Terms of Use)

Description Toni 2017-11-27 11:39:18 UTC
Description of problem:

Clementine doesn't work on Fedora 27. When I run Clementine from the terminal it shows this communicate:

 [d@localhost ~]$ clementine
15:12:18.587 WARN  unknown                          libpng warning: iCCP: known incorrect sRGB profile
15:12:18.698 WARN  unknown                          QPainter::begin: Paint device returned engine == 0, type: 2
15:12:18.976 WARN  unknown                          "sni-qt/11982" WARN  15:12:18.976 void StatusNotifierItemFactory::connectToSnw() Invalid interface to SNW_SERVICE  
15:12:18.976 WARN  unknown                          No systemtrayicon available
15:12:18.976 WARN  unknown                          Object::connect: No such signal QtSingleApplication::messageReceived(QByteArray)
15:12:18.976 WARN  unknown                          Object::connect:  (sender name:   'clementine')
15:12:18.976 WARN  unknown                          Object::connect:  (receiver name: 'MainWindow')
15:12:19.020 ERROR unknown                          JSonScanner::yylex - error while reading from io device  
15:12:19.020 ERROR unknown                          json_parser - syntax error found,  forcing abort, Line 1 Column 1  

Version-Release number of selected component (if applicable): Clementine from Fedora's software menager


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Toni 2017-11-27 11:50:33 UTC
Clementine doesn't work on Fedora 27 (GNOM shell)

Comment 2 Toni 2017-11-27 11:51:31 UTC
Clementine doesn't work on Fedora 27 (GNOME shell)

Comment 3 ValdikSS 2018-01-10 11:10:51 UTC
Try to remove configuration file.

Maintainer: take a look at https://github.com/clementine-player/Clementine/issues/5457

Comment 4 Rex Dieter 2018-04-06 14:24:27 UTC
it appears clementine may not fail gracefully if the environment used does provide any system tray icon support

You can try editing ~/.config/Clementine/Clementine.conf to include

[MainWindow]
showtray=false


and see if that helps?

(If so, probably worth adjusting clementine default to showtray=false, at least until this issue is fixed properly)

Comment 5 Rex Dieter 2018-04-06 14:28:47 UTC
Or if you have kreadconfig5/kwriteconfig5 available,

kwriteconfig5 --file Clementine/Clementine.conf --group MainWindow --key showtray false

Comment 6 Rex Dieter 2018-04-10 14:46:38 UTC
*** Bug 1519618 has been marked as a duplicate of this bug. ***

Comment 7 Jose Mantilla 2018-04-10 17:57:37 UTC
(In reply to Rex Dieter from comment #4)
> it appears clementine may not fail gracefully if the environment used does
> provide any system tray icon support
> 
> You can try editing ~/.config/Clementine/Clementine.conf to include
> 
> [MainWindow]
> showtray=false
> 
> 
> and see if that helps?
> 
> (If so, probably worth adjusting clementine default to showtray=false, at
> least until this issue is fixed properly)

Yes!!!, it works.

Thank you @Rex Dieter hahahaha, amazing solution.
Fixed for me on Fedora 27

Comment 8 Petr Hracek 2018-04-23 10:57:18 UTC
Waw,

showtray=false works also for me.
I had the same problem and now problem is fixed.
Great

Comment 9 Jonathan Underwood 2018-09-22 09:45:58 UTC
Problem persists on Fedora 28, and the workaround proposed by Rex fixes the problem.

Is this something that  is fixable at the packaging level, or more of an upstream issue? My guess is the latter.

Comment 10 Orcan Ogetbil 2018-09-22 13:23:51 UTC
To me this sounds like more of a Gnome bug.

Comment 11 Rex Dieter 2018-09-24 21:17:45 UTC
One packaging fix to consider: setting the 'showtray=false' to be the default behavior or more drastic... forcefully disable the feature completely.

Comment 12 Orcan Ogetbil 2018-09-24 23:28:12 UTC
Would that have any impact on non-Gnome desktops?

Comment 13 Rex Dieter 2018-09-25 13:33:27 UTC
Yes, systray feature would either be disabled by default... or disabled completely, depending on which approach you took.

Comment 14 Orcan Ogetbil 2018-09-25 13:50:53 UTC
I wonder if there is a way to tell the current DE (or window manager?). We can disable the tray conditional on the DE then.

I am not in the favor of disabling unconditionally. I use that feature, at the very least. 

Disabling by default might work initially, until a Gnome user decides to fiddle with their settings and hits this one. Then they would need to fix/remove their config file.

Comment 15 Orcan Ogetbil 2018-09-25 13:54:26 UTC
Maybe the $DESKTOP_SESSION environment variable. What is that equal to in Gnome?

Comment 16 Rex Dieter 2018-09-25 13:58:04 UTC
XDG_CURRENT_DESKTOP would probably be better option, if you want to go that route.

Comment 17 Orcan Ogetbil 2018-09-30 16:23:18 UTC
Can Gnome folks give this build a spin? It should work without the showtray=false workaround for the Gnome bug.

https://koji.fedoraproject.org/koji/taskinfo?taskID=29975300

Thanks!

Comment 18 Orcan Ogetbil 2018-10-03 05:13:04 UTC
Folks, it would be great if this gets some love with testing before the koji scratch build expires.

Comment 19 Jonathan Underwood 2018-10-04 08:44:14 UTC
Thanks Orcan.

I installed clementine.x86_64 1.3.1-27.1.fc28 from koji on a Fedora 28 machine that had been freshly installed (and so had never had clementine installed, and had no user config tweaks in place) and happily Clementine starts fine under a gnome session.

Comment 20 Orcan Ogetbil 2018-10-04 12:48:18 UTC
Awesome. Thank you Jonathan!

Comment 21 Fedora Update System 2018-10-05 05:43:16 UTC
clementine-1.3.1-28.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-27b3133d2c

Comment 22 Fedora Update System 2018-10-05 05:43:43 UTC
clementine-1.3.1-28.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-a40140d2ff

Comment 23 Fedora Update System 2018-10-05 05:44:14 UTC
clementine-1.3.1-28.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-1fe8f8cff2

Comment 24 Fedora Update System 2018-10-05 18:07:23 UTC
clementine-1.3.1-28.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-1fe8f8cff2

Comment 25 Fedora Update System 2018-10-05 18:23:54 UTC
clementine-1.3.1-28.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-27b3133d2c

Comment 26 Fedora Update System 2018-10-05 19:32:06 UTC
clementine-1.3.1-28.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-a40140d2ff

Comment 27 Fedora Update System 2018-10-16 11:38:23 UTC
clementine-1.3.1-28.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 28 Fedora Update System 2018-10-16 12:08:34 UTC
clementine-1.3.1-28.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 29 Fedora Update System 2018-10-30 17:20:25 UTC
clementine-1.3.1-28.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.