Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517740 - warning message about lacking 'ipset' package from ipfailover pod logs
Summary: warning message about lacking 'ipset' package from ipfailover pod logs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 3.7.0
Hardware: All
OS: All
medium
low
Target Milestone: ---
: 3.10.0
Assignee: Phil Cameron
QA Contact: zhaozhanqi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-27 10:59 UTC by zhaozhanqi
Modified: 2018-07-30 19:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: no doc changes needed Consequence: Fix: Result:
Clone Of:
Environment:
Last Closed: 2018-07-30 19:09:00 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:09:46 UTC
Origin (Github) 19426 None None None 2018-04-19 12:16:09 UTC

Description zhaozhanqi 2017-11-27 10:59:51 UTC
Description of problem:
Check the ipfailover pod logs after its running.

Registering Kernel netlink command channel
Registering gratuitous ARP shared channel
Opening file '/etc/keepalived/keepalived.conf'.
Initializing ipvs
Opening file '/etc/keepalived/keepalived.conf'.
Unable to load ipset library - libipset.so.3: cannot open shared object file: No such file or directory


Version-Release number of selected component (if applicable):
openshift3/ose-keepalived-ipfailover:v3.7.9


How reproducible:
always

Steps to Reproduce:
1. Create ipfailover pod
2. See logs when the pod become running
3.

Actual results:
Check the pod logs:

...
Registering gratuitous ARP shared channel
Opening file '/etc/keepalived/keepalived.conf'.
Unable to load ipset library - libipset.so.3: cannot open shared object file: No such file or directory
...

Expected results:

No this error

Additional info:

I checked there is upstream bug https://bugzilla.redhat.com/show_bug.cgi?id=1477572 for this.

Comment 1 Phil Cameron 2018-04-19 12:15:02 UTC
https://github.com/openshift/origin/pull/19428

Comment 2 openshift-github-bot 2018-04-24 09:01:10 UTC
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/e5a439628a3dd04a9ae54ec7acc6042053b878d3
ipfailover - add missing ipset/libipset to image

bug 1517740
https://bugzilla.redhat.com/show_bug.cgi?id=1517740

Signed-off-by: Phil Cameron <pcameron@redhat.com>

Comment 4 zhaozhanqi 2018-05-16 06:06:56 UTC
Verified this bug

When the ipfaiover pod become running. the related log "libipset.so.3: cannot open shared object file" do not be found.

Comment 6 errata-xmlrpc 2018-07-30 19:09:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.