Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517711 - A user with "Organization admin" role is not able to access "Content Hosts" page in the webui.
Summary: A user with "Organization admin" role is not able to access "Content Hosts" p...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Users & Roles
Version: 6.3.0
Hardware: x86_64
OS: Linux
high
high vote
Target Milestone: Unspecified
Assignee: Marek Hulan
QA Contact: Nikhil Kathole
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-27 09:49 UTC by Ashish Humbe
Modified: 2019-04-01 20:27 UTC (History)
8 users (show)

Fixed In Version: foreman-1.15.6.26-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-21 16:54:37 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 21343 None None None 2017-12-17 15:34:01 UTC
Red Hat Bugzilla 1502725 None None None Never

Internal Links: 1502725

Description Ashish Humbe 2017-11-27 09:49:42 UTC
Description of problem:

A user with "Organization admin" role is not able to access "Content Hosts" page in the webui.

Version-Release number of selected component (if applicable):
Satellite v 6.3 Beta SNAP 26

How reproducible:
Always

Steps to Reproduce:
1. Create a new user with "Organization Admin" role
2. Try to access Content Hosts 


Actual results:
The Org Admin user is able to list system profiles in the "All Hosts" page but not able to access list any system profiles on the "Content Hosts" page. 

Expected results:
Org Admin user should have access to list and manage content hosts, he should be able to set/change/remove Environment/Content View/Subscriptions etc to the system profile.

Comment 1 Marek Hulan 2017-11-27 11:48:46 UTC
Hello Ashish, is this a regression in snap 26 or was it observable with previous snaps too? Also note that you should not assign Organization Admin role directly, you should first create a clone of it and assign it some organization, then assign this clone to a user.

Comment 2 Ashish Humbe 2017-11-28 04:27:39 UTC
Hi Marek,

Not tested on earlier snaps, started testing yesterday after upgrading satellite from snap 25.

Aah not aware that we should be cloning it, any specific reason for this?

I created clone of default Org Admin role, assigned it to 2 orgs, still user with this cloned role can not list/access Content Host profiles. 

Whereas a user with Manager role can list profiles on the Content Host page.

Comment 3 Marek Hulan 2017-11-29 13:09:58 UTC
In beta, org admin is limited to single org. In GA, full support will be available (hopefully with few next snaps). Could you try it with single org. Also is a user being associated with single org? In my instance running last snap it seems to work.

Comment 4 Ashish Humbe 2017-12-08 10:17:26 UTC
Hi Marek,

Today I tested with Sat6.3 Public Beta, 

- Only one default org is present on the satellite server.
- Tried with the cloned "Organization Admin" user after associating org with it.
- Also tried with default Org Admin role without cloning it.

In all scenarios, I see that user with Org Admin role can on access Content Hosts page.

Is this issue addressed in public beta?

Regards,
Ashish

Comment 5 Brad Buckingham 2017-12-08 18:32:45 UTC
Hi Ashish,

Based on comment 4, does this mean that the issue is no longer being seen with the public beta?

If not, we do want to make sure this is resolved by GA.

Comment 7 Ashish Humbe 2017-12-11 10:28:23 UTC
Hi Brad,

Sorry for the confusion, the issue is still reproducible in Sat63 Public beta. 

We need to fix it. 

Thanks,
Ashish

Comment 8 Tomer Brisker 2017-12-17 14:51:07 UTC
API call for the host list returns "Organization not found by id '1'".
Root cause seems to be that org admin role doesn't have view_organization role for its organization. This also prevents org admin from listing any other resource when specifying organization or organization-id in the api or hammer.

Comment 9 Tomer Brisker 2017-12-17 14:53:56 UTC
Created redmine issue http://projects.theforeman.org/issues/21998 from this bug

Comment 10 pm-sat@redhat.com 2017-12-17 15:20:01 UTC
Upstream bug assigned to tbrisker@redhat.com

Comment 11 pm-sat@redhat.com 2017-12-17 15:20:05 UTC
Upstream bug assigned to tbrisker@redhat.com

Comment 12 Tomer Brisker 2017-12-17 15:34:02 UTC
This has already been fixed upstream, updating upstream tracker.

Comment 14 Marek Hulan 2018-01-02 16:54:21 UTC
Working on it as part of https://bugzilla.redhat.com/show_bug.cgi?id=1502725, this is a dup of it. I'm keeping it open for QA so they can also test this specific page under org admin.

Comment 15 Nikhil Kathole 2018-01-12 08:44:05 UTC
VERIFIED

version tested :
Satellite 6.3 snap 31

Steps:
1. Cloned organization_admin role
2. Created a user with cloned role
3. Login with created user
4. Navigated to Hots-> Content Host page

Found Org_admin user is able to access content host also the API call returns list of content host.

Comment 18 pm-sat@redhat.com 2018-02-21 16:54:37 UTC
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA.
> > 
> > For information on the advisory, and where to find the updated files, follow the link below.
> > 
> > If the solution does not work for you, open a new bug report.
> > 
> > https://access.redhat.com/errata/RHSA-2018:0336


Note You need to log in before you can comment on or make changes to this bug.