Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517643 - Deja-dup 36.3 segmentation fault after upgrade from Fedora 25 to 26
Summary: Deja-dup 36.3 segmentation fault after upgrade from Fedora 25 to 26
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: deja-dup
Version: 26
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-27 07:34 UTC by Andrea Vai
Modified: 2018-05-30 11:04 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-29 11:51:35 UTC


Attachments (Terms of Use)
Stacktrace (deleted)
2017-11-28 14:17 UTC, Andrea Vai
no flags Details


Links
System ID Priority Status Summary Last Updated
Launchpad 1735730 None None None 2017-12-01 13:46:01 UTC

Description Andrea Vai 2017-11-27 07:34:26 UTC
Description of problem:
After upgrade Fedora 25 to 26, deja-dup no longer works.

How reproducible:
run deja-dup from terminal, obtain segmentation fault.

version 36.3 on Fedora 26

Comment 1 Gwyn Ciesla 2017-11-27 15:05:06 UTC
Please try deja-dup-37.0-1.fc26 from updates-testing.

Comment 2 Andrea Vai 2017-11-28 07:26:04 UTC
I tried and obtained the same error

Comment 3 Gwyn Ciesla 2017-11-28 13:30:35 UTC
Can you run it with gdb and provide a backtrace?

Comment 4 Andrea Vai 2017-11-28 14:17:58 UTC
Created attachment 1359892 [details]
Stacktrace

gdb stacktrace

Comment 5 Andrea Vai 2017-11-28 14:19:17 UTC
Backtrace attached... not sure it is exactly what you need, btw, if it's not sorry, and please let me know how to get the correct backtrace

Comment 6 Gwyn Ciesla 2017-11-28 14:22:52 UTC
It's a good start. What storage type are you using?

Comment 7 Andrea Vai 2017-11-28 14:31:32 UTC
(In reply to Gwyn Ciesla from comment #6)
> It's a good start. What storage type are you using?

An ext4 SATA 2GB HD (whose filesystem is mounted as / and deja-dup is installed there), but let me point out that I am trying to start deja-dup without connecting my external USB hard drive. Maybe you mean "storage where deja-dup would save files to"? In that case, that storage is disconnected now, because I wanted to narrow down the problem. Does it make sense?

Comment 8 Gwyn Ciesla 2017-11-28 14:40:27 UTC
Yes, the backup destination, sorry for being unclear. :)

E_COFFEE

Does it crash the same way whether the drive is connected or not?

Comment 9 Andrea Vai 2017-11-28 14:53:50 UTC
(In reply to Gwyn Ciesla from comment #8)
> Yes, the backup destination, sorry for being unclear. :)
> 
> E_COFFEE
> 
> Does it crash the same way whether the drive is connected or not?

Appartently YES, but don't now it for sure... do you need a backtrace in this situation, too?

To be precise, the problem is a bit more complicated because it happens something slightly different:

- If I connect the USB Hard Disk:
  - the scheduled backup starts and fails (saying "Another duplicity instance is already running with this archive directory" in the deja-dup Gnome window)
    - if I leave the window open, running deja-dup from terminal outputs "GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying";
   - else, if I close the window and run deja-dup from terminal, it outputs the segfault only.

Comment 10 Gwyn Ciesla 2017-11-28 14:59:04 UTC
Do you have any duplicate RPMs on your system after the upgrade?

Comment 11 Andrea Vai 2017-11-28 15:07:46 UTC
Sorry, I cannot find a certain way to search for them... can I have a hint please? Thanks

Comment 12 Gwyn Ciesla 2017-11-28 15:11:34 UTC
sudo dnf repoquery --duplicates

If there are some, 

sudo dnf remove --duplicates

Also, check 

sudo dnf repoquery --unsatisfied

Comment 13 Andrea Vai 2017-11-28 15:14:13 UTC
both the commands

sudo dnf repoquery --duplicates

and

sudo dnf repoquery --unsatisfied

output is empty.

Comment 14 Gwyn Ciesla 2017-11-28 15:17:46 UTC
And you have duplicity 0.7.15-1?

Comment 15 Andrea Vai 2017-11-29 08:02:24 UTC
(In reply to Gwyn Ciesla from comment #14)
> And you have duplicity 0.7.15-1?

yes, exactly

Comment 16 Gwyn Ciesla 2017-11-29 15:45:19 UTC
Do backups work on a different storage destination, like ssh, smb, etc?

Comment 17 Andrea Vai 2017-11-29 16:04:03 UTC
Yeah, I would like to give some tries, but the problem is that in no way I am able to run the program :-/ ... or, am I missing something?

Comment 18 Gwyn Ciesla 2017-11-29 16:15:33 UTC
Try changing the settings, you can do so with gsettings. See what's available with:

gsettings list-recursively org.gnome.DejaDup

Comment 19 Andrea Vai 2017-12-01 08:04:31 UTC
I have done some tries:
- deleted all old backup files from my backup drive, to be sure the problem is not related to them
- changed the "include list" in dconf, and set it to "['/tmp']" (quotes for clarity only), to be sure the problem is not related to it

--> the backup starts when I connect the USB drive, completes correctly, but if I run deja-dup from terminal I get segfault again. So, the only way I know to run the backup here is by connecting the drive (also by tweaking the last-backup time, setting it to the past, to trigger it immediately)

- changed backend from "drive" to "local" in dconf

--> again, running deja-dup (from terminal or by the gnome menu) does not work, so I run it by setting the last-backup parameter in dconf. The backup starts and completes correctly.

- also tried to backup to a smb share --> same behaviour

So, it seems to me that the segfault is not related to anything pointed out above.

Comment 20 Gwyn Ciesla 2017-12-01 13:46:52 UTC
Ok, I'm out of ideas. I filed an upstream bug.

Comment 21 Fedora End Of Life 2018-05-03 08:08:49 UTC
This message is a reminder that Fedora 26 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 26. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '26'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 26 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 22 Fedora End Of Life 2018-05-29 11:51:35 UTC
Fedora 26 changed to end-of-life (EOL) status on 2018-05-29. Fedora 26
is no longer maintained, which means that it will not receive any
further security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Comment 23 Andrea Vai 2018-05-30 11:04:51 UTC
Now working with deja-dup 37.1, duplicity 0.7.17 in F27


Note You need to log in before you can comment on or make changes to this bug.