Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517580 - libgstallocators-1.0.so.0, needed by /usr/bin/gnome-help, not found
Summary: libgstallocators-1.0.so.0, needed by /usr/bin/gnome-help, not found
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: lorax
Version: 26
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-27 02:12 UTC by rav
Modified: 2018-01-04 20:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-28 00:23:57 UTC


Attachments (Terms of Use)

Description rav 2017-11-27 02:12:08 UTC
Hi all.

Description of problem:

Version-Release number of selected component (if applicable):
mock-1.4.7-2.fc26
lorax-26.9-1.fc26

How reproducible:
I'am trying to build installer via inside mock.

Steps to Reproduce:
1. cat /etc/mock/fedora-26-x86_64_iso.cfg
config_opts['root'] = 'fedora-26-x86_64_iso'
config_opts['target_arch'] = 'x86_64'
config_opts['legal_host_arches'] = ('x86_64',)
config_opts['chroot_setup_cmd'] = 'install @buildsys-build'
config_opts['dist'] = 'fc26'  # only useful for --resultdir variable subst
config_opts['extra_chroot_dirs'] = [ '/run/lock', ]
config_opts['releasever'] = '26'
config_opts['rpmbuild_networking'] = True
config_opts['basedir'] = '/home/mock/'
config_opts['internal_setarch'] = True
config_opts['environment']['TERM'] = 'xterm-256color'
config_opts['internal_dev_setup'] = False

# repos
[fedora]
name=fedora
baseurl=http://mirror.yandex.ru/fedora/linux/releases/$releasever/Everything/$basearch/os/
enabled=1

[updates]
name=updates
baseurl=http://mirror.yandex.ru/fedora/linux/updates/$releasever/$basearch/
enabled=1

[rpmfusion-free]
name=RPM Fusion for Fedora $releasever - Free
baseurl=http://mirror.yandex.ru/fedora/rpmfusion/free/fedora/releases/$releasever/Everything/$basearch/os/
enabled=1

[rpmfusion-free-updates]
name=RPM Fusion for Fedora $releasever - Free - Updates
baseurl=http://mirror.yandex.ru/fedora/rpmfusion/free/fedora/updates/$releasever/$basearch/
enabled=1

2. Do not pay attention to my internal variables - it doesn't matter.

mock -r fedora-26-x86_64_iso --old-chroot --shell "bash /root/make.sh"

cat make.sh
...
setenforce 0 
lorax -p Fedora -v $VERSION -r $VERSION -s "file://$BUILD_DIR/tmp/" \
-s "http://mirror.yandex.ru/fedora/linux/releases/$VERSION/Everything/$ARCH/os/" \
-s "http://mirror.yandex.ru/fedora/linux/updates/$VERSION/$ARCH/" \
--buildarch "$ARCH" --volid "$DIST-$VERSION-$ARCH" --logfile=$BUILD_DIR/tmp/lorax.log --tmp=$BUILD_DIR/tmp/ --isfinal $ISO_DIR --nomacboot \
--installpkgs="gstreamer1-plugins-base" \
--excludepkgs="yelp" \
 || exit 1
setenforce 1
...

3. Here is result:
2017-11-27 04:42:39,702: libgstallocators-1.0.so.0, needed by /usr/bin/gnome-help, not found
libgstallocators-1.0.so.0, needed by /usr/bin/gnome-help, not found
2017-11-27 04:42:39,704: libgstallocators-1.0.so.0, needed by /usr/bin/yelp, not found
libgstallocators-1.0.so.0, needed by /usr/bin/yelp, not found
Finish: shell


Additional info: as u can see yelp depends on gstreamer1-plugins-base.
Its strange, but if i add gstreamer1-plugins-base to install packages list (via --installpkgs option), but it doesn't help.
I also tried to remove yelp from install packages list (via --excludepkgs option)but it doesn't work (may be it's because anaconda-gui depends on yelp).

Comment 1 Brian Lane 2017-11-27 21:34:41 UTC
This is a problem with the repositories you are using, not with lorax.

Comment 2 rav 2017-11-27 23:30:27 UTC
Hi Brian.
I tried to get mirror from this how to:
https://rhinstaller.github.io/lorax/lorax.html

Im my case i get this command:

setenforce 0 
lorax -p Fedora -v $VERSION -r $VERSION \
-s "http://mirrorservice.org/sites/dl.fedoraproject.org/pub/fedora/linux/releases/$VERSION/Everything/$ARCH/os/" \
-s "http://mirrorservice.org/sites/dl.fedoraproject.org/pub/fedora/linux/updates/$VERSION/$ARCH/" \
--buildarch "$ARCH" --volid "$DIST-$VERSION-$ARCH" --logfile=$BUILD_DIR/tmp/lorax.log --tmp=$BUILD_DIR/tmp/ --isfinal $ISO_DIR --nomacboot \
 || exit 1
setenforce 1


But, unfortunally, get the same results:
2017-11-28 02:23:28,412: verifying the installroot
verifying the installroot
2017-11-28 02:23:30,593: libgstallocators-1.0.so.0, needed by /usr/bin/gnome-help, not found
libgstallocators-1.0.so.0, needed by /usr/bin/gnome-help, not found
2017-11-28 02:23:30,595: libgstallocators-1.0.so.0, needed by /usr/bin/yelp, not found
libgstallocators-1.0.so.0, needed by /usr/bin/yelp, not found
Finish: shell

What I am doing wrong?

Comment 3 Brian Lane 2017-11-28 00:23:57 UTC
Try using dl.fedoraproject.org directly and see if that works, mirrors sometimes lag or are not synchronized correctly.

This kind of error is not a lorax problem. It's an issue with the repos being used.

Comment 4 Robert Van Voorhees 2018-01-04 14:03:30 UTC
I attempted using dl.fedoraproject.org and the problem is continuing.  Since the kickstart file I am attempting to build does not contain a graphical UI, I'm wondering why gnome-help is necessary at all.  Do you think this might be a problem with the installroot template missing a dependency?  It doesn't look like that uses yum or dnf to build the dependency tree and install relies on directly installing packages.

Comment 5 Brian Lane 2018-01-04 16:51:49 UTC
Lorax uses dnf to depsolve the packages, so it could very well be pulled in by something else. Using dnf repoquery --whatrequires gnome-help may reveal it, if it is a direct dependency.

Comment 6 Robert Van Voorhees 2018-01-04 20:12:25 UTC
I think I found the culprit:

/usr/share/lorax/templates.d/99-generic/runtime-cleanup.tmpl

I modified this part:

## Clean up some of the mess pulled in by webkitgtk via yelp
## libwebkit2gtk links to a handful of libraries in gstreamer and
## gstreamer-plugins-base. Remove the rest of them.
removefrom gstreamer1 --allbut /usr/${libdir}/libgstbase-1.0.* \
                               /usr/${libdir}/libgstreamer-1.0.*
removefrom gstreamer1-plugins-base --allbut \
        /usr/${libdir}/libgst{app,audio,fft,pbutils,tag,video}-1.0.*

So that the last line includes allocators

In other words:

removefrom gstreamer1-plugins-base --allbut \
        /usr/${libdir}/libgst{app,audio,fft,pbutils,tag,video,allocators}-1.0.*

That stops it from removing the library, and I am once again able to build the kickstart.


Note You need to log in before you can comment on or make changes to this bug.