Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517571 - [abrt] solaar: update(): window.py:775:update:AssertionError
Summary: [abrt] solaar: update(): window.py:775:update:AssertionError
Keywords:
Status: CLOSED DUPLICATE of bug 1487640
Alias: None
Product: Fedora
Classification: Fedora
Component: solaar
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Eric Smith
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:0b4f091cd18ed4ef28f440d046f...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-26 22:47 UTC by Robert Hancock
Modified: 2018-07-27 21:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-27 21:18:34 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2017-11-26 22:47 UTC, Robert Hancock
no flags Details
File: cgroup (deleted)
2017-11-26 22:47 UTC, Robert Hancock
no flags Details
File: cpuinfo (deleted)
2017-11-26 22:47 UTC, Robert Hancock
no flags Details
File: environ (deleted)
2017-11-26 22:47 UTC, Robert Hancock
no flags Details
File: mountinfo (deleted)
2017-11-26 22:47 UTC, Robert Hancock
no flags Details
File: namespaces (deleted)
2017-11-26 22:47 UTC, Robert Hancock
no flags Details
File: open_fds (deleted)
2017-11-26 22:47 UTC, Robert Hancock
no flags Details

Description Robert Hancock 2017-11-26 22:47:11 UTC
Version-Release number of selected component:
solaar-0.9.2-4.20150528gitcf27328.fc27.6

Additional info:
reporter:       libreport-2.9.3
cmdline:        /usr/bin/python /usr/bin/solaar
crash_function: update
exception_type: AssertionError
executable:     /usr/bin/solaar
kernel:         4.13.15-300.fc27.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
window.py:775:update:AssertionError

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/solaar/ui/__init__.py", line 165, in _status_changed
    window.update(device, need_popup)
  File "/usr/lib/python2.7/site-packages/solaar/ui/window.py", line 775, in update
    assert item
AssertionError

Local variables in innermost frame:
device: <UnifyingReceiver(/dev/hidraw3,15)>
item: None
is_alive: False
selected_device_id: None
need_popup: 0

Potential duplicate: bug 1506862

Comment 1 Robert Hancock 2017-11-26 22:47:17 UTC
Created attachment 1359227 [details]
File: backtrace

Comment 2 Robert Hancock 2017-11-26 22:47:18 UTC
Created attachment 1359228 [details]
File: cgroup

Comment 3 Robert Hancock 2017-11-26 22:47:19 UTC
Created attachment 1359229 [details]
File: cpuinfo

Comment 4 Robert Hancock 2017-11-26 22:47:20 UTC
Created attachment 1359230 [details]
File: environ

Comment 5 Robert Hancock 2017-11-26 22:47:21 UTC
Created attachment 1359231 [details]
File: mountinfo

Comment 6 Robert Hancock 2017-11-26 22:47:22 UTC
Created attachment 1359232 [details]
File: namespaces

Comment 7 Robert Hancock 2017-11-26 22:47:23 UTC
Created attachment 1359233 [details]
File: open_fds

Comment 8 Jason Tibbitts 2018-07-27 21:18:34 UTC

*** This bug has been marked as a duplicate of bug 1487640 ***


Note You need to log in before you can comment on or make changes to this bug.