Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517541 - [git_script_t] SELinux is preventing git from map access on the file /var/lib/git/ansible.git/objects/pack/pack-277152cd4f4e150f5bdd3c0a5d13bbf9eb946d69.idx
Summary: [git_script_t] SELinux is preventing git from map access on the file /var/lib...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-26 15:45 UTC by Juan Orti Alcaine
Modified: 2018-01-02 16:48 UTC (History)
6 users (show)

Fixed In Version: selinux-policy-3.13.1-283.19.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-02 16:48:08 UTC


Attachments (Terms of Use)

Description Juan Orti Alcaine 2017-11-26 15:45:31 UTC
I use gitweb to access my git repositories.

SELinux is preventing git from map access on the file /var/lib/git/ansible.git/objects/pack/pack-277152cd4f4e150f5bdd3c0a5d13bbf9eb946d69.idx.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that git should be allowed map access on the pack-277152cd4f4e150f5bdd3c0a5d13bbf9eb946d69.idx file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'git' --raw | audit2allow -M my-git
# semodule -X 300 -i my-git.pp


Additional Information:
Source Context                system_u:system_r:git_script_t:s0
Target Context                system_u:object_r:git_rw_content_t:s0
Target Objects                /var/lib/git/ansible.git/objects/pack/pack-277152c
                              d4f4e150f5bdd3c0a5d13bbf9eb946d69.idx [ file ]
Source                        git
Source Path                   git
Port                          <Unknown>
Host                          helio
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-283.16.fc27.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     helio
Platform                      Linux helio 4.13.13-300.fc27.x86_64 #1 SMP Wed Nov
                              15 15:47:50 UTC 2017 x86_64 x86_64
Alert Count                   6
First Seen                    2017-11-26 16:43:17 CET
Last Seen                     2017-11-26 16:43:17 CET
Local ID                      663a339a-3ab5-4c53-8312-3fbfc6d67023

Raw Audit Messages
type=AVC msg=audit(1511710997.504:8774): avc:  denied  { map } for  pid=6516 comm="git" path="/var/lib/git/ansible.git/objects/pack/pack-277152cd4f4e150f5bdd3c0a5d13bbf9eb946d69.idx" dev="dm-4" ino=2435 scontext=system_u:system_r:git_script_t:s0 tcontext=system_u:object_r:git_rw_content_t:s0 tclass=file permissive=0


Hash: git,git_script_t,git_rw_content_t,file,map

Comment 1 John Obaterspok 2017-12-03 08:03:35 UTC
I believe this is a duplicate of 1514866 which has been resolved. (selinux-policy update package has been provided since end of november).

Comment 2 Juan Orti Alcaine 2017-12-03 09:00:52 UTC
I'm still getting these errors with selinux-policy-3.13.1-283.17.fc27.noarch

Comment 3 Fedora Update System 2017-12-13 08:26:47 UTC
selinux-policy-3.13.1-283.18.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8225c4e502

Comment 4 Fedora Update System 2017-12-14 11:12:13 UTC
selinux-policy-3.13.1-283.18.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8225c4e502

Comment 5 Fedora Update System 2017-12-20 11:24:36 UTC
selinux-policy-3.13.1-283.19.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8225c4e502

Comment 6 Fedora Update System 2017-12-21 20:21:17 UTC
selinux-policy-3.13.1-283.19.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8225c4e502

Comment 7 Fedora Update System 2018-01-02 16:48:08 UTC
selinux-policy-3.13.1-283.19.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.