Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517518 - Wrong fontname for NimbusSansNarrow-BoldOblique in Fontmap.GS
Summary: Wrong fontname for NimbusSansNarrow-BoldOblique in Fontmap.GS
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ghostscript
Version: 27
Hardware: noarch
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: David Kaspar [Dee'Kej]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1515481 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-26 11:11 UTC by Wolfgang Gradl
Modified: 2017-12-12 11:22 UTC (History)
4 users (show)

Fixed In Version: ghostscript-9.22-3.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-12 11:22:35 UTC


Attachments (Terms of Use)
EPS file which mentions Helvetica-Narrow-BoldOblique, and which fails to display with gs 9.22 (deleted)
2017-11-26 11:11 UTC, Wolfgang Gradl
no flags Details


Links
System ID Priority Status Summary Last Updated
Ghostscript 698784 None None None 2017-11-27 16:02:20 UTC

Description Wolfgang Gradl 2017-11-26 11:11:44 UTC
Created attachment 1359135 [details]
EPS file which mentions Helvetica-Narrow-BoldOblique, and which fails to display with gs 9.22

Description of problem:
Font configuration of ghostscript in Resource/Init/Fontmap.GS refers to
NimbusSansNarrow-BdOblique (as an alias for Helvetica-Narrow-BoldOblique),
which cannot be found:

Running gs c1.eps (on the attachment) produces

Loading NimbusSansNarrow-Bold font from /usr/share/fonts/urw-base35/NimbusSansNarrow-Bold.t1... 9084404 7660552 11252216 9778935 2 done.
Can't find (or can't open) font file /usr/share/ghostscript/9.22/Resource/Font/NimbusSansNarrow-BdOblique.
Can't find (or can't open) font file NimbusSansNarrow-BdOblique.
Can't find (or can't open) font file /usr/share/ghostscript/9.22/Resource/Font/NimbusSansNarrow-BdOblique.
Can't find (or can't open) font file NimbusSansNarrow-BdOblique.
Didn't find this font on the system!
Unable to substitute for font.
Error: /invalidfont in /findfont
Operand stack:
   --nostringval--   Helvetica-Narrow-BoldOblique
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1999   1   3   %oparray_pop   1998   1   3   %oparray_pop   --nostringval--   1982   1   3   %oparray_pop   1868   1   3   %oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   %array_continue   --nostringval--   1951   2   4   %oparray_pop
Dictionary stack:
   --dict:980/1684(ro)(G)--   --dict:0/20(G)--   --dict:82/200(L)--   --dict:67/80(L)--
Current allocation mode is local
Last OS error: Not a directory
Current file position is 6201
GPL Ghostscript 9.22: Unrecoverable error, exit code 1


Version-Release number of selected component (if applicable):
ghostscript-9.22-1.fc27.x86_64
urw-base35-fonts-20170801-2.fc27.noarch



How reproducible:
Always reproducible.  Attached EPS file is a minimum reproducer.


Steps to Reproduce:
Create EPS file which mentions font Helvetica-Narrow-BoldOblique (note that the
font needs not be used in the actual plot; the bug appears when the font is
mentioned in the Preamble).
Run gs, gv, or any other viewer/program which relies on ghostscript to display or otherwise show EPS files

Actual results:
Error, see above

Expected results:
EPS file is shown on display.

Additional info:
The following patch fixes the problem:
$ diff -u /usr/share/ghostscript/9.22/Resource/Init/Fontmap.GS.old /usr/share/ghostscript/9.22/Resource/Init/Fontmap.GS
--- /usr/share/ghostscript/9.22/Resource/Init/Fontmap.GS.old	2017-11-25 10:13:53.909366458 +0100
+++ /usr/share/ghostscript/9.22/Resource/Init/Fontmap.GS	2017-11-25 17:17:13.212881405 +0100
@@ -96,7 +96,7 @@
 /Helvetica-Bold			/NimbusSans-Bold ;
 /Helvetica-BoldOblique		/NimbusSans-BoldItalic      ;
 /Helvetica-Narrow-Bold		/NimbusSansNarrow-Bold    ;
-/Helvetica-Narrow-BoldOblique	/NimbusSansNarrow-BdOblique        ;
+/Helvetica-Narrow-BoldOblique	/NimbusSansNarrow-BoldOblique        ;
 /Helvetica-Narrow		/NimbusSansNarrow-Regular    ;
 /Helvetica-Narrow-Oblique	/NimbusSansNarrow-Oblique        ;
 /Helvetica			/NimbusSans-Regular ;


(It's the font name, not the file name, which seems to be relevant in Fontmap.GS).

Comment 1 David Kaspar [Dee'Kej] 2017-11-27 16:02:20 UTC
I have informed upstream about this (created a new BZ for it). I hope to speak with them about this tomorrow. If they accept the patch, I can roll it out by tomorrow or Wednesday. :)

Thanks for the report! ;)

Comment 2 David Kaspar [Dee'Kej] 2017-11-28 10:57:45 UTC
*** Bug 1515481 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2017-12-04 13:38:40 UTC
ghostscript-9.22-3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d42b712a8a

Comment 4 Wolfgang Gradl 2017-12-05 06:39:40 UTC
The update ghostscript-9.22-3.fc27 (from updates-testing) fixes the problem for me.  Thank you very much for the quick reaction!

Comment 5 Fedora Update System 2017-12-08 23:27:08 UTC
ghostscript-9.22-3.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d42b712a8a

Comment 6 Fedora Update System 2017-12-12 11:22:35 UTC
ghostscript-9.22-3.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.