Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517494 - Missing plugin: gstreamer|1.0|totem|DVD subpicture decoder|decoder-subpicture/x-dvd (DVD subpicture decoder)
Summary: Missing plugin: gstreamer|1.0|totem|DVD subpicture decoder|decoder-subpicture...
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-26 07:37 UTC by Steve
Modified: 2019-04-05 22:36 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)
Screenshot from gnome-software (deleted)
2017-11-26 07:37 UTC, Steve
no flags Details

Description Steve 2017-11-26 07:37:46 UTC
Created attachment 1359077 [details]
Screenshot from gnome-software

Description of problem:
Totem is missing the plugin DVD subpicture decoder and gnome-software does not find gstreamer1-plugins-bad-freeworld. After installing gstreamer1-plugins-bad-freeworld manually, playing works.

$ totem
** Message: Missing plugin: gstreamer|1.0|totem|DVD subpicture decoder|decoder-subpicture/x-dvd (DVD subpicture decoder)

Version-Release number of selected component (if applicable):
totem-3.26.0-1.fc27.x86_64
gnome-software-3.26.3-1.fc27.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Open a video file that needs the plugin to play properly
2. Error comes up: "Unable to play the file" >> Find in Software
3. Error comes up: "Unable do Find Requested Software"
4. Install gstreamer1-plugins-bad-freeworld from livna
5. Totem plays the file

Actual results:


Expected results:
Gnome-software should find gstreamer1-plugins-bad-freeworld when lifna repo is installed

Additional info:

Comment 1 Steve 2018-06-19 18:06:51 UTC
Bug persists in Fedora 28, totem-3.26.0-7.fc28.x86_64, gnome-software-3.28.2-1.fc28.x86_64.

Comment 2 Steve 2018-11-05 04:47:36 UTC
Bug persists in Fedora 29, totem-3.26.2-1.fc29.x86_64, gnome-software-3.30.5-1.fc29.x86_64.

Comment 3 German Pulido 2018-11-05 13:56:44 UTC
Just a note that the Livna repo does not carry this package anymore since a long time ago, it merged with RPMFusion, however the workaround to this issue, even on Fedora 29 is still manually installing the "gstreamer1-plugins-bad-freeworld" package using dnf:

# sudo dnf install gstreamer1-plugins-bad-freeworld

Comment 4 Steve 2018-11-05 14:46:12 UTC
(In reply to German Pulido from comment #3)
> Just a note that the Livna repo does not carry this package anymore since a
> long time ago, it merged with RPMFusion, however the workaround to this
> issue, even on Fedora 29 is still manually installing the
> "gstreamer1-plugins-bad-freeworld" package using dnf:
> 
> # sudo dnf install gstreamer1-plugins-bad-freeworld

You're right, I wrote that wrong above. Of course ist ist RPMFusion.


Note You need to log in before you can comment on or make changes to this bug.