Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517491 - OSP-12 CI job failed with Error: image rhosp12/openstack-aodh-api-docker:20171123.3 not found
Summary: OSP-12 CI job failed with Error: image rhosp12/openstack-aodh-api-docker:201...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: ---
Assignee: James Slagle
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-26 07:09 UTC by Eran Kuris
Modified: 2017-12-21 14:21 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-21 14:21:54 UTC


Attachments (Terms of Use)

Description Eran Kuris 2017-11-26 07:09:59 UTC
Description of problem:
OSP-12 CI job failed with  Error:

09:37:41 TASK [containers/environment-setup : openstack overcloud container image upload] ***
09:37:41 task path: /home/rhos-ci/jenkins/workspace/DFG-network-neutron-lbaas-12_director-rhel-virthost-3cont_2comp-ipv4-vlan/infrared/plugins/tripleo-overcloud/roles/containers/environment-setup/tasks/build_images.yml:85
09:37:41                       [[ previous task time: 0:00:00.243766 = 0.24s / 94.47s ]]
09:37:41 fatal: [undercloud-0]: FAILED! => {
09:37:41     "changed": true, 
09:37:41     "cmd": "source /home/stack/stackrc\n openstack overcloud container image upload --verbose --config-file /home/stack/container_images.yaml", 
09:37:41     "delta": "0:00:33.198495", 
09:37:41     "end": "2017-11-25 04:37:37.953214", 
09:37:41     "failed": true, 
09:37:41     "rc": 1, 
09:37:41     "start": "2017-11-25 04:37:04.754719"
09:37:41 }
09:37:41 
09:37:41 STDERR:
09:37:41 
09:37:41 START with options: [u'overcloud', u'container', u'image', u'upload', u'--verbose', u'--config-file', u'/home/stack/container_images.yaml']
09:37:41 command: overcloud container image upload -> tripleoclient.v1.container_image.UploadImage (auth=False)
09:37:41 Using config files: [u'/home/stack/container_images.yaml']
09:37:41 imagename: rhosp12/openstack-aodh-api-docker:20171123.3
09:37:41 docker pull failed: Error: image rhosp12/openstack-aodh-api-docker:20171123.3 not found
09:37:41 retrying pulling image: docker-registry.engineering.redhat.com/rhosp12/openstack-aodh-api-docker
09:37:41 docker pull failed: Error: image rhosp12/openstack-aodh-api-docker:20171123.3 not found
09:37:41 retrying pulling image: docker-registry.engineering.redhat.com/rhosp12/openstack-aodh-api-docker
09:37:41 docker pull failed: Error: image rhosp12/openstack-aodh-api-docker:20171123.3 not found
09:37:41 retrying pulling image: docker-registry.engineering.redhat.com/rhosp12/openstack-aodh-api-docker
09:37:41 docker pull failed: Error: image rhosp12/openstack-aodh-api-docker:20171123.3 not found
09:37:41 retrying pulling image: docker-registry.engineering.redhat.com/rhosp12/openstack-aodh-api-docker
09:37:41 docker pull failed: Error: image rhosp12/openstack-aodh-api-docker:20171123.3 not found
09:37:41 retrying pulling image: docker-registry.engineering.redhat.com/rhosp12/openstack-aodh-api-docker
09:37:41 Could not pull image docker-registry.engineering.redhat.com/rhosp12/openstack-aodh-api-docker
09:37:41 END return value: 1
Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-7.0.3-9.el7ost.noarch
python-tripleoclient-7.3.3-4.el7ost.noarch
openstack-tripleo-validations-7.4.2-1.el7ost.noarch
openstack-tripleo-puppet-elements-7.0.1-0.20171103211052.82d7e6c.el7ost.noarch
openstack-tripleo-image-elements-7.0.1-0.20171103210122.2e61e31.el7ost.noarch
openstack-tripleo-image-elements-7.0.1-0.20171103210122.2e61e31.el7ost.noarch
openstack-tripleo-common-7.6.3-3.el7ost.noarch
puppet-tripleo-7.4.3-6.el7ost.noarch
openstack-tripleo-ui-7.4.3-4.el7ost.noarch

How reproducible:
always

Steps to Reproduce:
1.run OSP12 CI jobs 
2.
3.

Actual results:
https://rhos-qe-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/view/DFG/view/network/view/neutron-lbaas/job/DFG-network-neutron-lbaas-12_director-rhel-virthost-3cont_2comp-ipv4-vlan/lastSuccessfulBuild/artifact/

Expected results:


Additional info:

Comment 2 Sorin Sbarnea 2017-11-27 14:15:07 UTC
If I am not wrong the reason why this happened is because the "-docker" suffix was removed from the image names.

Still, this happened without updating things like http://rhos-qe-mirror-tlv.usersys.redhat.com/rcm-guest/puddles/OpenStack/12.0-RHEL-7/latest/container_images.yaml

I don't know who is publishing the "rcm-guest" but I am inclined to believe that this MUST be part of the puddle build so we would never advertise a new puddle that cannot really be consumed.

Comment 3 Thierry Vignaud 2017-12-04 13:47:32 UTC
No suffix change was done.
As CI has succeeded several time, I would close it as a one time failure.

Comment 4 Mike Burns 2017-12-21 14:21:54 UTC
Closing WORKSFORME.  If this reproduces please reopen or file a new BZ.


Note You need to log in before you can comment on or make changes to this bug.