Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517424 - [WA] : New port numbers are not being reflected , even after 90 mins of volume restart.
Summary: [WA] : New port numbers are not being reflected , even after 90 mins of volum...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-gluster-integration
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Nishanth Thomas
QA Contact: Vijay Avuthu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-25 06:22 UTC by Ambarish
Modified: 2017-12-18 04:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 04:38:26 UTC


Attachments (Terms of Use)
OldPort (deleted)
2017-11-25 06:22 UTC, Ambarish
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3478 normal SHIPPED_LIVE RHGS Web Administration packages 2017-12-18 09:34:49 UTC

Description Ambarish 2017-11-25 06:22:07 UTC
Description of problem:
------------------------

Restarted a Gluster Volume visible in tendrl UI.

New ports are assigned to bricks post volume restarts.

*Before restart* : Ports = 49152,49154.

arbiter-2/gqas004.sbu.lab.eng.bos.redhat.com-bricks-arbiter-3.pid -S /var/run/gluster/ec5a9683478a0b41cb903ec5d90cd14f.socket --brick-name /bricks/arbiter-3 -l /var/log/glusterfs/bricks/bricks-arbiter-3.log --xlator-option *-posix.glusterd-uuid=f6b80b93-aa90-43db-969b-29551fac7e33 --brick-port 49152 --xlator-option arbiter-2-server.listen-port=49152

root     28092     1  0 Nov24 ?        00:12:04 /usr/sbin/glusterfsd -s gqas004.sbu.lab.eng.bos.redhat.com --volfile-id arbiter-2.gqas004.sbu.lab.eng.bos.redhat.com.bricks-arbiter_2 -p /var/run/gluster/vols/arbiter-2/gqas004.sbu.lab.eng.bos.redhat.com-bricks-arbiter_2.pid -S /var/run/gluster/796e54317318773e63e53f46d3e52b1c.socket --brick-name /bricks/arbiter_2 -l /var/log/glusterfs/bricks/bricks-arbiter_2.log --xlator-option *-posix.glusterd-uuid=f6b80b93-aa90-43db-969b-29551fac7e33 --brick-port 49154 --xlator-option arbiter-2-server.listen-port=49154


*After Volume restart* : Ports : 49157,49158

root     18260     1  0 00:32 ?        00:00:00 /usr/sbin/glusterfsd -s gqas004.sbu.lab.eng.bos.redhat.com --volfile-id arbiter-2.gqas004.sbu.lab.eng.bos.redhat.com.bricks-arbiter_2 -p /var/run/gluster/vols/arbiter-2/gqas004.sbu.lab.eng.bos.redhat.com-bricks-arbiter_2.pid -S /var/run/gluster/796e54317318773e63e53f46d3e52b1c.socket --brick-name /bricks/arbiter_2 -l /var/log/glusterfs/bricks/bricks-arbiter_2.log --xlator-option *-posix.glusterd-uuid=f6b80b93-aa90-43db-969b-29551fac7e33 --brick-port 49157 --xlator-option arbiter-2-server.listen-port=49157

root     18284     1  0 00:32 ?        00:00:00 /usr/sbin/glusterfsd -s gqas004.sbu.lab.eng.bos.redhat.com --volfile-id arbiter-2.gqas004.sbu.lab.eng.bos.redhat.com.bricks-arbiter-3 -p /var/run/gluster/vols/arbiter-2/gqas004.sbu.lab.eng.bos.redhat.com-bricks-arbiter-3.pid -S /var/run/gluster/ec5a9683478a0b41cb903ec5d90cd14f.socket --brick-name /bricks/arbiter-3 -l /var/log/glusterfs/bricks/bricks-arbiter-3.log --xlator-option *-posix.glusterd-uuid=f6b80b93-aa90-43db-969b-29551fac7e33 --brick-port 49158 --xlator-option arbiter-2-server.listen-port=49158


UI shows port number as 49152,49154 even after one and a half hours of volume restart.

Screenshot attached.

Version-Release number of selected component (if applicable):
-------------------------------------------------------------

[root@gqac015 ~]# rpm -qa|grep tendrl
tendrl-commons-1.5.4-4.el7rhgs.noarch
tendrl-grafana-selinux-1.5.3-2.el7rhgs.noarch
tendrl-node-agent-1.5.4-5.el7rhgs.noarch
tendrl-api-httpd-1.5.4-2.el7rhgs.noarch
tendrl-grafana-plugins-1.5.4-5.el7rhgs.noarch
tendrl-notifier-1.5.4-3.el7rhgs.noarch
tendrl-ansible-1.5.4-1.el7rhgs.noarch
tendrl-api-1.5.4-2.el7rhgs.noarch
tendrl-ui-1.5.4-4.el7rhgs.noarch
tendrl-monitoring-integration-1.5.4-5.el7rhgs.noarch
tendrl-selinux-1.5.3-2.el7rhgs.noarch


How reproducible:
-----------------

1/1

Comment 2 Ambarish 2017-11-25 06:22:55 UTC
Created attachment 1358896 [details]
OldPort

Comment 10 errata-xmlrpc 2017-12-18 04:38:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3478


Note You need to log in before you can comment on or make changes to this bug.