Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517408 - bcc-tools Man page entry for trace(8) conflicts with postfix's trace (inverse is also true)
Summary: bcc-tools Man page entry for trace(8) conflicts with postfix's trace (inverse...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bcc
Version: 26
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Jiri Olsa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1517569 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-25 00:08 UTC by Kevin Faulkner
Modified: 2017-12-12 13:41 UTC (History)
4 users (show)

Fixed In Version: bcc-0.4.0-2.fc27 bcc-0.4.0-2.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-12 11:18:02 UTC


Attachments (Terms of Use)

Description Kevin Faulkner 2017-11-25 00:08:41 UTC
Description of problem:
man pages for "trace" conflict once one is installed:
```
<snip>
Total size: 1.4 M
Installed size: 3.9 M
Is this ok [y/N]: y
Downloading Packages:
[SKIPPED] postfix-3.2.4-1.fc26.x86_64.rpm: Already downloaded                                                                                                                                                                                                 
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/share/man/man8/trace.8.gz from install of postfix-2:3.2.4-1.fc26.x86_64 conflicts with file from package bcc-tools-0.4.0-1.fc26.noarch

Error Summary
------------
```

Version-Release number of selected component (if applicable):
postfix-3.2.4-1.fc26.x86_64
bcc-tools-0.4.0-1.fc26.noarch

How reproducible:
just install one of the packages first bcc-tools or postfix, then try to install the other one, the conflict should be observable

Steps to Reproduce:
1. dnf install -y bcc-tools
2. dnf install -y postfix
3.

Actual results:


Expected results:
Both packages install along side, this would be useful in server environments occasionally in desktop environments 

Additional info:

Comment 1 Rafael Fonseca 2017-11-26 22:52:25 UTC
*** Bug 1517569 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2017-11-27 13:47:50 UTC
bcc-0.4.0-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-c3e26e8757

Comment 3 Fedora Update System 2017-11-27 13:58:03 UTC
bcc-0.4.0-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-5733c2e10a

Comment 4 Fedora Update System 2017-11-28 06:46:05 UTC
bcc-0.4.0-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-c3e26e8757

Comment 5 Fedora Update System 2017-11-28 07:24:43 UTC
bcc-0.4.0-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-5733c2e10a

Comment 6 Fedora Update System 2017-12-12 11:18:02 UTC
bcc-0.4.0-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2017-12-12 13:41:05 UTC
bcc-0.4.0-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.