Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517405 - SELinux is preventing plymouthd from 'map' accesses on the chr_file /dev/fb0.
Summary: SELinux is preventing plymouthd from 'map' accesses on the chr_file /dev/fb0.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e462dbee4e3ba9367a2778f507b...
: 1482350 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-24 23:04 UTC by Yusoo
Modified: 2018-03-19 13:33 UTC (History)
18 users (show)

Fixed In Version: selinux-policy-3.13.1-283.19.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1551842 (view as bug list)
Environment:
Last Closed: 2018-01-02 16:47:35 UTC


Attachments (Terms of Use)

Description Yusoo 2017-11-24 23:04:16 UTC
Description of problem:
SELinux is preventing plymouthd from 'map' accesses on the chr_file /dev/fb0.

*****  Plugin catchall (100. confidence) suggests   **************************

If plymouthd는 디폴트로 fb0 chr_file에서 map 액세스를 허용해야 합니다. 
Then 이 버그를 보고해야 합니다. 
이러한 액세스를 허용하기 위해 로컬 정채 모듈을 생성할 수 있습니다. 
Do
allow this access for now by executing:
# ausearch -c 'plymouthd' --raw | audit2allow -M my-plymouthd
# semodule -X 300 -i my-plymouthd.pp

Additional Information:
Source Context                system_u:system_r:plymouthd_t:s0
Target Context                system_u:object_r:framebuf_device_t:s0
Target Objects                /dev/fb0 [ chr_file ]
Source                        plymouthd
Source Path                   plymouthd
Port                          <알려지지 않음>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-283.16.fc27.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.13.13-300.fc27.x86_64 #1 SMP Wed
                              Nov 15 15:47:50 UTC 2017 x86_64 x86_64
Alert Count                   1
First Seen                    2017-11-24 21:19:51 KST
Last Seen                     2017-11-24 21:19:51 KST
Local ID                      93ac0d30-0f1f-434d-a776-2f79a8fad532

Raw Audit Messages
type=AVC msg=audit(1511525991.715:281): avc:  denied  { map } for  pid=11983 comm="plymouthd" path="/dev/fb0" dev="devtmpfs" ino=1035 scontext=system_u:system_r:plymouthd_t:s0 tcontext=system_u:object_r:framebuf_device_t:s0 tclass=chr_file permissive=0


Hash: plymouthd,plymouthd_t,framebuf_device_t,chr_file,map

Version-Release number of selected component:
selinux-policy-3.13.1-283.16.fc27.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.3
hashmarkername: setroubleshoot
kernel:         4.13.9-300.fc27.x86_64
type:           libreport

Potential duplicate: bug 1482350

Comment 1 Lukas Vrabec 2017-12-11 15:19:26 UTC
*** Bug 1482350 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2017-12-13 08:25:49 UTC
selinux-policy-3.13.1-283.18.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8225c4e502

Comment 3 Fedora Update System 2017-12-14 11:11:43 UTC
selinux-policy-3.13.1-283.18.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8225c4e502

Comment 4 Fedora Update System 2017-12-20 11:23:38 UTC
selinux-policy-3.13.1-283.19.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8225c4e502

Comment 5 Fedora Update System 2017-12-21 20:20:50 UTC
selinux-policy-3.13.1-283.19.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8225c4e502

Comment 6 Fedora Update System 2018-01-02 16:47:35 UTC
selinux-policy-3.13.1-283.19.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Marc Jadoul 2018-01-06 10:44:04 UTC
Hello,
I have the same error. 
Actually I am using NVIDIA driver because Nouveau locked several time on my laptop. 
My laptop boot. Wayland is disabled in GSM config. After boot when I log in, my graphical interface freeze including the mouse . 
After reboot I can see this selinux error.... But there may be other errors.

Comment 8 Marc Jadoul 2018-01-06 10:45:47 UTC
NB: I have the right selinux policy installed.

Comment 9 Benjamin Masse 2018-01-11 22:19:03 UTC
Description of problem:
selinux-policy-3.13.1-283.21.fc27.noarch with proprietary NVIDIA drivers installed.

Version-Release number of selected component:
selinux-policy-3.13.1-283.19.fc27.noarch

Additional info:
reporter:       libreport-2.9.3
hashmarkername: setroubleshoot
kernel:         4.14.11-300.fc27.x86_64
type:           libreport

Comment 10 pixxxx 2018-02-04 01:31:27 UTC
*** Bug 1541689 has been marked as a duplicate of this bug. ***

Comment 11 Chad 2018-02-20 18:54:10 UTC
Description of problem:

type=AVC msg=audit(1519152096.009:449): avc:  denied  { map } for  pid=3998 comm="plymouthd" path="/dev/fb0" dev="devtmpfs" ino=2076 scontext=system_u:system_r:plymouthd_t:s0 tcontext=system_u:object_r:framebuf_device_t:s0 tclass=chr_file permissive=0

Version-Release number of selected component:

selinux-policy-3.13.1-283.24.fc27.noarch

Comment 12 Antonio Fortes 2018-03-16 13:08:47 UTC
Description of problem:
This problem ocurred during reboot, and there was a software update the day before.

Version-Release number of selected component:
selinux-policy-3.13.1-283.26.fc27.noarch

Additional info:
reporter:       libreport-2.9.3
hashmarkername: setroubleshoot
kernel:         4.15.8-300.fc27.x86_64
type:           libreport


Note You need to log in before you can comment on or make changes to this bug.