Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517376 - docker pull failed: Error: image rhosp12/openstack-aodh-api-docker:20171123.3 not found
Summary: docker pull failed: Error: image rhosp12/openstack-aodh-api-docker:20171123.3...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-containers
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Jon Schlueter
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-24 17:23 UTC by Dan Yasny
Modified: 2017-11-27 22:21 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-27 22:21:14 UTC


Attachments (Terms of Use)

Description Dan Yasny 2017-11-24 17:23:22 UTC
Description of problem:

[stack@undercloud-0 ~]$ . stackrc 
(undercloud) [stack@undercloud-0 ~]$ openstack overcloud container image upload --verbose --config-file /home/stack/container_images.yaml
START with options: [u'overcloud', u'container', u'image', u'upload', u'--verbose', u'--config-file', u'/home/stack/container_images.yaml']
command: overcloud container image upload -> tripleoclient.v1.container_image.UploadImage (auth=False)
Using config files: [u'/home/stack/container_images.yaml']
imagename: rhosp12/openstack-aodh-api-docker:20171123.3
docker pull failed: Error: image rhosp12/openstack-aodh-api-docker:20171123.3 not found
retrying pulling image: docker-registry.engineering.redhat.com/rhosp12/openstack-aodh-api-docker
docker pull failed: Error: image rhosp12/openstack-aodh-api-docker:20171123.3 not found
retrying pulling image: docker-registry.engineering.redhat.com/rhosp12/openstack-aodh-api-docker
docker pull failed: Error: image rhosp12/openstack-aodh-api-docker:20171123.3 not found
retrying pulling image: docker-registry.engineering.redhat.com/rhosp12/openstack-aodh-api-docker
docker pull failed: Error: image rhosp12/openstack-aodh-api-docker:20171123.3 not found
retrying pulling image: docker-registry.engineering.redhat.com/rhosp12/openstack-aodh-api-docker
docker pull failed: Error: image rhosp12/openstack-aodh-api-docker:20171123.3 not found
retrying pulling image: docker-registry.engineering.redhat.com/rhosp12/openstack-aodh-api-docker
Could not pull image docker-registry.engineering.redhat.com/rhosp12/openstack-aodh-api-docker
END return value: 1



Version-Release number of selected component (if applicable):

20171123.3

openstack-swift-proxy-2.15.1-3.el7ost.noarch
openstack-ironic-api-9.1.2-3.el7ost.noarch
openstack-tripleo-common-7.6.3-4.el7ost.noarch
openstack-mistral-engine-5.2.0-1.el7ost.noarch
openstack-nova-scheduler-16.0.2-2.el7ost.noarch
openstack-swift-account-2.15.1-3.el7ost.noarch
puppet-openstack_extras-11.3.0-2.el7ost.noarch
openstack-neutron-openvswitch-11.0.1-5.el7ost.noarch
openstack-heat-engine-9.0.1-3.el7ost.noarch
python-openstackclient-lang-3.12.0-1.el7ost.noarch
openstack-zaqar-5.0.0-3.el7ost.noarch
openstack-tripleo-puppet-elements-7.0.1-1.el7ost.noarch
openstack-heat-common-9.0.1-3.el7ost.noarch
openstack-puppet-modules-11.0.0-1.el7ost.noarch
openstack-tripleo-ui-7.4.3-4.el7ost.noarch
openstack-glance-15.0.0-3.el7ost.noarch
openstack-tripleo-common-containers-7.6.3-4.el7ost.noarch
openstack-tripleo-heat-templates-7.0.3-12.el7ost.noarch
openstack-swift-object-2.15.1-3.el7ost.noarch
openstack-heat-api-9.0.1-3.el7ost.noarch
openstack-ironic-common-9.1.2-3.el7ost.noarch
openstack-mistral-api-5.2.0-1.el7ost.noarch
openstack-nova-api-16.0.2-2.el7ost.noarch
openstack-nova-conductor-16.0.2-2.el7ost.noarch
openstack-swift-container-2.15.1-3.el7ost.noarch
openstack-neutron-ml2-11.0.1-5.el7ost.noarch
openstack-heat-api-cfn-9.0.1-3.el7ost.noarch
openstack-nova-common-16.0.2-2.el7ost.noarch
openstack-neutron-11.0.1-5.el7ost.noarch
openstack-ironic-conductor-9.1.2-3.el7ost.noarch
openstack-tempest-17.1.0-1.el7ost.noarch
python-openstackclient-3.12.0-1.el7ost.noarch
openstack-mistral-executor-5.2.0-1.el7ost.noarch
openstack-keystone-12.0.0-3.el7ost.noarch
puppet-openstacklib-11.3.0-2.el7ost.noarch
openstack-nova-compute-16.0.2-2.el7ost.noarch
openstack-neutron-common-11.0.1-5.el7ost.noarch
openstack-ironic-inspector-6.0.0-3.el7ost.noarch
python-openstacksdk-0.9.17-1.el7ost.noarch
openstack-tripleo-image-elements-7.0.1-1.el7ost.noarch
openstack-mistral-common-5.2.0-1.el7ost.noarch
openstack-tripleo-validations-7.4.2-1.el7ost.noarch
openstack-selinux-0.8.11-1.el7ost.noarch
openstack-nova-placement-api-16.0.2-2.el7ost.noarch



How reproducible:
always

Steps to Reproduce:
1. install undercloud and try to build a docker repo
2.
3.

Actual results:
as above

Expected results:


Additional info:

Comment 1 Dan Yasny 2017-11-24 17:49:02 UTC
When I check for the latest tag I get a different output:

$ openstack overcloud container image tag discover --image docker-registry.engineering.redhat.com/rhosp12/openstack-base:latest --tag-from-label version-release

12.0-20171122.1

So 20171123.3 doesn't exist

Comment 2 Pradeep Kilambi 2017-11-27 17:11:42 UTC
This looks like a release delivery issue to me. I'm sure all containers will have this issue if the tag is missing.

Comment 3 Jon Schlueter 2017-11-27 22:21:14 UTC
Issue was due to inconsistency in updating the registry and build artifacts.  Images are available for 2017-11-27.5 and 2017-11-27.14 puddles.  Issue was identified and fixed, but long term solution for keeping things in sync and working cleanly is not yet implemented.


Note You need to log in before you can comment on or make changes to this bug.