Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517324 - Ansible 2.4 from rhel-7-server-extras-rpms breaks OSE installer
Summary: Ansible 2.4 from rhel-7-server-extras-rpms breaks OSE installer
Keywords:
Status: CLOSED DUPLICATE of bug 1516469
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.5.0
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Scott Dodson
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-24 15:33 UTC by Ahmed Ossama
Modified: 2017-11-24 17:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-24 17:41:08 UTC


Attachments (Terms of Use)

Description Ahmed Ossama 2017-11-24 15:33:18 UTC
Description of problem:

Installing a vanilla OSE 3.5 (and probably 3.6, I haven't tried it yet) as detailed in the documentation causes the installer to fail.

Version-Release number of the following components:

# rpm -q openshift-ansible
openshift-ansible-3.5.145-1.git.0.e1e330f.el7.noarch

# rpm -q ansible
ansible-2.4.1.0-1.el7.noarch

# ansible --version
ansible 2.4.1.0
  config file = /etc/ansible/ansible.cfg
  configured module search path = [u'/root/.ansible/plugins/modules', u'/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python2.7/site-packages/ansible
  executable location = /usr/bin/ansible
  python version = 2.7.5 (default, Aug  2 2016, 04:20:16) [GCC 4.8.5 20150623 (Red Hat 4.8.5-4)]


How reproducible:
Follow the exact same steps in the official documentation for OSE 3.5.

Steps to Reproduce:
1.
2.
3.

Actual results:
ERROR! no action detected in task. This often indicates a misspelled module name, or incorrect module path.

The error appears to have been in '/usr/share/ansible/openshift-ansible/roles/etcd/tasks/system_container.yml': line 22, column 3, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:


- name: Install or Update Etcd system container package
  ^ here


The error appears to have been in '/usr/share/ansible/openshift-ansible/roles/etcd/tasks/system_container.yml': line 22, column 3, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:


- name: Install or Update Etcd system container package
  ^ here

exception type: <class 'ansible.errors.AnsibleParserError'>
exception: no action detected in task. This often indicates a misspelled module name, or incorrect module path.

The error appears to have been in '/usr/share/ansible/openshift-ansible/roles/etcd/tasks/system_container.yml': line 22, column 3, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:


- name: Install or Update Etcd system container package
  ^ here


An error was detected. After resolving the problem please relaunch the
installation process.

Expected results:
The installer should start installing OCP as below:

Are you ready to continue? [y/N]: y

Play 1/28 (Create initial host groups for localhost)
..
Play 2/28 (Create initial host groups for all hosts)


Additional info:
Instead of depending on ansible provided from the rhel-7-server-extras-rpms, use the ansible package provided from the relavent OSE repository (rhel-7-server-ose-3.5-rpms):

# yum remove ansible
# yum --disablerepo=rhel-7-server-extras-rpms install atomic-openshift-utils

Comment 1 Scott Dodson 2017-11-24 17:41:08 UTC

*** This bug has been marked as a duplicate of bug 1516469 ***


Note You need to log in before you can comment on or make changes to this bug.