Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517277 - Could not able to view info of compute-resource image passing name for all parameters
Summary: Could not able to view info of compute-resource image passing name for all pa...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Compute Resources
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Lukáš Hellebrandt
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-24 13:04 UTC by Nikhil Kathole
Modified: 2019-02-07 12:03 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-07 12:03:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 22408 None None None 2018-01-24 13:33:54 UTC

Description Nikhil Kathole 2017-11-24 13:04:50 UTC
Description of problem: Compute-resource image info need to pass id for at least one of the parameter. Not able to view info of compute-resource image passing name of all required parameters.

Version-Release number of selected component (if applicable): Satellite 6.3 snap 25


How reproducible: always


Steps to Reproduce:
1.# hammer -v -u admin -p changeme --output=csv compute-resource create --datacenter="Default" --url="https://URL/api" --user="admin" --provider="Ovirt" --password="password" --name="test"
Message,Id,Name
Compute resource created,7,test

2. # hammer -v -u admin -p changeme --output=csv compute-resource image create --username="root" --password="password" --operatingsystem="RedHat 6.8" --name="test_image" --uuid="Default" --compute-resource="test" --architecture="x86_64"
Message,Id,Name
Image created,3,test_image

3. # hammer compute-resource image info --compute-resource 'test' --name 'test_image'
missing param 'operatingsystem_id' in parameters

4. # hammer compute-resource image info --name test_image --compute-resource 'test' --operatingsystem="RedHat 6.8"
missing param 'operatingsystem_id' in parameters


Actual results: 

Not able to view info of compute-resource image passing --compute-resource name and --name name of image.


Expected results:

Compute-resource image should display info passing --compute-resource name and --name name of image as parameters.


Additional info: If one of the parameter passed as id, successfully showed info.

# hammer compute-resource image info --compute-resource 'test' --id 3
Id:               3
Name:             test_image
Operating System: RedHat 6.8
Username:         root
UUID:             Default
Architecture:     x86_64
IAM role:
Created at:       2017/11/24 11:24:51
Updated at:       2017/11/24 11:24:51

# hammer compute-resource image info --compute-resource-id 7 --name 'test_image'
Id:               3
Name:             test_image
Operating System: RedHat 6.8
Username:         root
UUID:             Default
Architecture:     x86_64
IAM role:
Created at:       2017/11/24 11:24:51
Updated at:       2017/11/24 11:24:51

Comment 4 Ondřej Pražák 2018-01-24 13:33:51 UTC
Created redmine issue http://projects.theforeman.org/issues/22408 from this bug

Comment 5 Bryan Kearney 2018-11-30 15:00:59 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Rich Jerrido or Bryan Kearney or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 6 Bryan Kearney 2019-02-07 12:03:52 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.