Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517265 - OSP10 -> OSP11 upgrade: major-upgrade-composable-steps.yaml fails with Error: ceilometer-upgrade --skip-metering-database returned 1 instead of one of [0]
Summary: OSP10 -> OSP11 upgrade: major-upgrade-composable-steps.yaml fails with Error:...
Keywords:
Status: CLOSED DUPLICATE of bug 1517977
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: z4
: 11.0 (Ocata)
Assignee: Angus Thomas
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-24 12:43 UTC by Marius Cornea
Modified: 2017-12-06 14:42 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-heat-templates-6.2.4-3.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-06 14:42:17 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 521621 None None None 2017-11-27 15:00:40 UTC
OpenStack gerrit 521886 None None None 2017-11-27 15:00:17 UTC
OpenStack gerrit 521890 None None None 2017-11-27 14:59:52 UTC

Description Marius Cornea 2017-11-24 12:43:31 UTC
Description of problem:
OSP10 -> OSP11 upgrade: major-upgrade-composable-steps.yaml fails with Error: ceilometer-upgrade --skip-metering-database returned 1 instead of one of [0]

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-6.2.4-1.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP10
2. Upgrade to OSP11

Actual results:
Upgrade fails.

Expected results:
Upgrade succeeds.

Additional info:
[stack@undercloud-0 ~]$ openstack stack failures list overcloud
overcloud.AllNodesDeploySteps.AllNodesPostUpgradeSteps.ControllerDeployment_Step5.0:
  resource_type: OS::Heat::StructuredDeployment
  physical_resource_id: 13eceed5-fdad-4b24-8e72-46e35213db66
  status: CREATE_FAILED
  status_reason: |
    Error: resources[0]: Deployment to server failed: deploy_status_code : Deployment exited with non-zero status code: 6
  deploy_stdout: |
    ...
    Debug: Finishing transaction 106225340
    Debug: Storing state
    Debug: Stored state in 0.81 seconds
    Notice: Applied catalog in 309.50 seconds
    Debug: Applying settings catalog for sections reporting, metrics
    Debug: Finishing transaction 324013700
    Debug: Received report to process from controller-0.localdomain
    Debug: Evicting cache entry for environment 'production'
    Debug: Caching environment 'production' (ttl = 0 sec)
    Debug: Processing report from controller-0.localdomain with processor Puppet::Reports::Store
    (truncated, view all with --long)
  deploy_stderr: |
    ging rabbit_host, rabbit_hosts, rabbit_port, rabbit_userid, rabbit_password, rabbit_virtual_host parameters have been deprecated by the [DEFAULT]\transport_url. Please use oslo::messaging::default::transport_url instead.
    Warning: Scope(Oslo::Messaging::Rabbit[neutron_config]): The oslo_messaging rabbit_host, rabbit_hosts, rabbit_port, rabbit_userid, rabbit_password, rabbit_virtual_host parameters have been deprecated by the [DEFAULT]\transport_url. Please use oslo::messaging::default::transport_url instead.
    Warning: Scope(Oslo::Messaging::Rabbit[ceilometer_config]): The oslo_messaging rabbit_host, rabbit_hosts, rabbit_port, rabbit_userid, rabbit_password, rabbit_virtual_host parameters have been deprecated by the [DEFAULT]\transport_url. Please use oslo::messaging::default::transport_url instead.
    Warning: Scope(Oslo::Messaging::Rabbit[aodh_config]): The oslo_messaging rabbit_host, rabbit_hosts, rabbit_port, rabbit_userid, rabbit_password, rabbit_virtual_host parameters have been deprecated by the [DEFAULT]\transport_url. Please use oslo::messaging::default::transport_url instead.
    Warning: Scope(Oslo::Messaging::Rabbit[sahara_config]): The oslo_messaging rabbit_host, rabbit_hosts, rabbit_port, rabbit_userid, rabbit_password, rabbit_virtual_host parameters have been deprecated by the [DEFAULT]\transport_url. Please use oslo::messaging::default::transport_url instead.
    Warning: Scope(Haproxy::Config[haproxy]): haproxy: The $merge_options parameter will default to true in the next major release. Please review the documentation regarding the implications.
    Error: ceilometer-upgrade --skip-metering-database returned 1 instead of one of [0]
    Error: /Stage[main]/Tripleo::Profile::Base::Ceilometer::Collector/Exec[ceilometer-db-upgrade]/returns: change from notrun to 0 failed: ceilometer-upgrade --skip-metering-database returned 1 instead of one of [0]

Comment 2 Carlos Camacho 2017-11-27 14:59:53 UTC
The fixes are merged and backported:

https://review.openstack.org/#/q/60925faefc58d76adf3914f96c636ca2a5b8c783

Comment 5 Steve Linabery 2017-12-06 13:17:45 UTC
We also have https://bugzilla.redhat.com/show_bug.cgi?id=1517977. Should either of 1517265 (this) or 1517977 be marked as a duplicate?

Comment 6 Marius Cornea 2017-12-06 13:20:15 UTC
(In reply to Steve Linabery from comment #5)
> We also have https://bugzilla.redhat.com/show_bug.cgi?id=1517977. Should
> either of 1517265 (this) or 1517977 be marked as a duplicate?

I'm ok with marking any of them as dupe as long as we get the fix in the next puddle.

Comment 7 Steve Linabery 2017-12-06 14:42:17 UTC

*** This bug has been marked as a duplicate of bug 1517977 ***


Note You need to log in before you can comment on or make changes to this bug.