Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517250 - New Repo not visible despite its presence in manifest
Summary: New Repo not visible despite its presence in manifest
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories
Version: 6.2.12
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-24 11:39 UTC by Vasishta
Modified: 2019-04-01 20:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-29 22:25:03 UTC


Attachments (Terms of Use)

Description Vasishta 2017-11-24 11:39:01 UTC
Description of problem:
While trying to configure satellite 6.2 for RHCEPH 3.0 (yet in stage), a repo is not visible under list of repositories.

Version-Release number of selected component (if applicable):
satellite-6.2.12-6.0.el7sat.noarch

How reproducible:
Always

Manifest has below lines under derived products, where as it was not able for us to find corresponding repo under https://<satellite-server>/katello/providers/redhat_provider 

$ rct cat-manifest stage2.zip |grep "ceph-tools/3"
		/content/dist/rhel/server/7/7Server/$basearch/rhceph-tools/3/debug
		/content/dist/rhel/server/7/7Server/$basearch/rhceph-tools/3/os
		/content/dist/rhel/server/7/7Server/$basearch/rhceph-tools/3/source/SRPMS


The manifest was downloaded from stage and "Employee SKU" subscription was used.

Additional info -
When a normal node was attached to stage, tools repo was available and respective packages were available with Employee SKU

Comment 3 Craig Donnelly 2017-11-29 22:25:03 UTC
This is not an issue with Satellite.

The Satellite simply consumes the product content offered from the manifest, and what is listed and available from the Red Hat CDN.

It appears you are just looking for something that is no longer being presented in the way it once was.

engId 281 does contain:

            "content": {
                "arches": null,
                "contentUrl": "/content/dist/rhel/server/7/7Server/$basearch/rhceph-tools/3/os",
                "created": "2017-10-07T18:53:48.000+0000",
                "entityVersion": 1295898615,
                "gpgUrl": "file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release",
                "id": "6652",
                "label": "rhel-7-server-rhceph-3-tools-rpms",
                "metadataExpire": 86400,
                "modifiedProductIds": [],
                "name": "Red Hat Ceph Storage 3 for Red Hat Enterprise Linux 7 Server (RPMs)",
                "releaseVersion": null,
                "requiredTags": "rhel-7-server",
                "type": "yum",
                "updated": "2017-10-07T18:53:48.000+0000",
                "uuid": "8a99f9815eef3002015ef82fb0321c24",
                "vendor": "Red Hat"
            },
            "enabled": false,
            "entityVersion": 481356546

The important note here is that since this is now being added to engId 281, and not RHEL engId's (69, etc..), you will need to refer to that product when locating this repository: Red Hat Ceph Storage.

The name is also really non-descriptive in that this repo is supposed to be Tools for RHEL 7. The above name would make me think that this should be a repository for installing the full Ceph product on RHEL 7, but at least the repo label is for tools.

I would recommend for the future that you test with a SKU for your product however, and not the Employee SKU - no telling what issues you might find with that. Since you are using Stage, you should be able to find some Ceph specific SKUs there.

I am going to close this out, since I have had no issue locating this product via a stage manifest within Satellite 6.2.12-6.

If you have further issues locating it, let me know. Based on your comment with the manifest contents - I don't imagine you will.

I have filed a JIRA with the repository inconsistencies that you can locate here: https://projects.engineering.redhat.com/browse/RCM-25142


Note You need to log in before you can comment on or make changes to this bug.