Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517239 - SELinux is preventing modprobe from 'module_load' accesses on the system Unknown.
Summary: SELinux is preventing modprobe from 'module_load' accesses on the system Unkn...
Keywords:
Status: CLOSED DUPLICATE of bug 1513399
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:66817961f7246011bb5678f9346...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-24 11:26 UTC by Allan Poulsen
Modified: 2017-12-13 12:43 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-13 12:43:38 UTC


Attachments (Terms of Use)

Description Allan Poulsen 2017-11-24 11:26:37 UTC
Description of problem:
Having OpenVSwitch started on an upgraded fedora 27 system
SELinux is preventing modprobe from 'module_load' accesses on the system Unknown.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that modprobe should be allowed module_load access on the Unknown system by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'modprobe' --raw | audit2allow -M my-modprobe
# semodule -X 300 -i my-modprobe.pp

Additional Information:
Source Context                system_u:system_r:openvswitch_t:s0
Target Context                system_u:system_r:openvswitch_t:s0
Target Objects                Unknown [ system ]
Source                        modprobe
Source Path                   modprobe
Port                          <Ukendt>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-225.22.fc25.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.12.13-200.fc25.x86_64 #1 SMP Thu
                              Sep 14 16:12:37 UTC 2017 x86_64 x86_64
Alert Count                   177
First Seen                    2017-02-27 20:58:55 CET
Last Seen                     2017-10-03 10:02:22 CEST
Local ID                      76fe997e-3222-421d-b8dd-3f48755791df

Raw Audit Messages
type=AVC msg=audit(1507017742.764:120): avc:  denied  { module_load } for  pid=1335 comm="modprobe" scontext=system_u:system_r:openvswitch_t:s0 tcontext=system_u:system_r:openvswitch_t:s0 tclass=system permissive=1


Hash: modprobe,openvswitch_t,openvswitch_t,system,module_load

Version-Release number of selected component:
selinux-policy-3.13.1-225.22.fc25.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.3
hashmarkername: setroubleshoot
kernel:         4.13.13-300.fc27.x86_64
type:           libreport

Comment 1 Lukas Vrabec 2017-12-13 12:43:38 UTC

*** This bug has been marked as a duplicate of bug 1513399 ***


Note You need to log in before you can comment on or make changes to this bug.