Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517230 - Web admin interface doesn't load anymore in google chrome
Summary: Web admin interface doesn't load anymore in google chrome
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: ovirt-4.2.0
: ---
Assignee: Greg Sheremeta
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-24 11:13 UTC by Sandro Bonazzola
Modified: 2018-02-20 09:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-29 17:07:04 UTC
oVirt Team: UX
oourfali: ovirt-4.2?
oourfali: planning_ack?
oourfali: devel_ack?
oourfali: testing_ack?


Attachments (Terms of Use)
screenshot (deleted)
2017-11-24 11:13 UTC, Sandro Bonazzola
no flags Details
works for me (deleted)
2017-11-27 13:47 UTC, Greg Sheremeta
no flags Details

Description Sandro Bonazzola 2017-11-24 11:13:46 UTC
Created attachment 1358620 [details]
screenshot

Description of problem:
Chrome console shows:

/ovirt-engine/webadm…y-additions.min.css Failed to load resource: net::ERR_INSECURE_RESPONSE
/ovirt-engine/webadm…rt.brand/common.css Failed to load resource: net::ERR_INSECURE_RESPONSE
/ovirt-engine/webadm….brand/webadmin.css Failed to load resource: net::ERR_INSECURE_RESPONSE
jquery.min.js Failed to load resource: net::ERR_INSECURE_RESPONSE
jquery-ui.min.js Failed to load resource: net::ERR_INSECURE_RESPONSE
bootstrap.min.js Failed to load resource: net::ERR_INSECURE_RESPONSE
patternfly.min.js Failed to load resource: net::ERR_INSECURE_RESPONSE
patternfly-functions…av-custom-3.26.1.js Failed to load resource: net::ERR_INSECURE_RESPONSE
insQ.min.js Failed to load resource: net::ERR_INSECURE_RESPONSE
webadmin.nocache.js Failed to load resource: net::ERR_INSECURE_RESPONSE


Version-Release number of selected component (if applicable):
ovirt-engine-4.2.0-0.0.master.20171122115834.git3549ed1.el7.centos.noarch

How reproducible:
Single test, didn't try to reproduce

Steps to Reproduce:
1. CentOS Minimal updated to latest content available (system is in Italian)
2. installed http://resources.ovirt.org/pub/yum-repo/ovirt-release-master.rpm
3. yum install ovirt-engine
4. executed engine-setup with proposed defaults
5. connected to the engine with google-chrome-stable-62.0.3202.94-1.x86_64 on Fedora 27
6. login to web admin i nterface

Actual results:
See attached screenshot

Expected results:
a page should be loaded and rendered

Additional info:
connecting with firefox-57.0-2.fc27.x86_64 works.
It used to work in chrome up to 4.2.0 beta2 release and I'm not aware of any change in the build process excluding chrome support.

Comment 2 Greg Sheremeta 2017-11-27 13:47:39 UTC
Created attachment 1359469 [details]
works for me

Comment 3 Greg Sheremeta 2017-11-27 13:50:38 UTC
works for me following your steps -- fresh master engine, yum updated centos 7 and the same Chrome, 62.0.3202.94 (although, Chrome on Fedora 26 instead of 27)

so lowering priority and removing blocker flag.

Sandro, can you ping me on chat and share access to your centos install?

Comment 4 Greg Sheremeta 2017-11-29 17:07:04 UTC
Let me know if you see it again. Hopefully just an environment issue.

Comment 5 Sandro Bonazzola 2018-02-20 09:49:58 UTC
Can't reproduce on oVirt 4.2.2 RC1


Note You need to log in before you can comment on or make changes to this bug.