Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517228 - java.lang.IllegalArgumentException: Invalid character found in method name. HTTP method names must be tokens
Summary: java.lang.IllegalArgumentException: Invalid character found in method name. H...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management
Version: 6.2.12
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: jcallaha
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-24 11:04 UTC by Ben
Modified: 2019-02-07 12:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-07 12:03:51 UTC


Attachments (Terms of Use)

Description Ben 2017-11-24 11:04:50 UTC
Description of problem:
Every Thursday morning at ~09:38 I see these messages in my /var/log/messages file:

ov 23 09:38:27 satellite1 server: Nov 23, 2017 9:38:27 AM org.apache.coyote.http11.AbstractHttp11Processor process
Nov 23 09:38:27 satellite1 server: Note: further occurrences of HTTP header parsing errors will be logged at DEBUG level.
Nov 23 09:38:27 satellite1 server: java.lang.IllegalArgumentException: Invalid character found in method name. HTTP method names must be tokens
Nov 23 09:38:27 satellite1 server: at org.apache.coyote.http11.InternalInputBuffer.parseRequestLine(InternalInputBuffer.java:136)
Nov 23 09:38:27 satellite1 server: at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1000)
Nov 23 09:38:27 satellite1 server: at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:637)
Nov 23 09:38:27 satellite1 server: at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:316)
Nov 23 09:38:27 satellite1 server: at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1152)
Nov 23 09:38:27 satellite1 server: at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:622)
Nov 23 09:38:27 satellite1 server: at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
Nov 23 09:38:27 satellite1 server: at java.lang.Thread.run(Thread.java:748)
Nov 23 09:38:27 satellite1 server: Nov 23, 2017 9:38:27 AM org.apache.coyote.http11.AbstractHttp11Processor process
Nov 23 09:38:27 satellite1 server: Note: further occurrences of HTTP header parsing errors will be logged at DEBUG level.
Nov 23 09:38:27 satellite1 server: java.lang.IllegalArgumentException: Invalid character found in method name. HTTP method names must be tokens
Nov 23 09:38:27 satellite1 server: at org.apache.coyote.http11.InternalInputBuffer.parseRequestLine(InternalInputBuffer.java:136)
Nov 23 09:38:27 satellite1 server: at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1000)
Nov 23 09:38:27 satellite1 server: at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:637)
Nov 23 09:38:27 satellite1 server: at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:316)
Nov 23 09:38:27 satellite1 server: at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1152)
Nov 23 09:38:27 satellite1 server: at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:622)
Nov 23 09:38:27 satellite1 server: at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
Nov 23 09:38:27 satellite1 server: at java.lang.Thread.run(Thread.java:748)

What's going on on Thursday morning around then?


Version-Release number of selected component (if applicable):
RHEL7
Satellite 6.2.12-5

How reproducible:
/var/log/messages:Nov 23 09:38:27 satellite1 server: java.lang.IllegalArgumentException: Invalid character found in method name. HTTP method names must be tokens
/var/log/messages:Nov 23 09:38:27 satellite1 server: java.lang.IllegalArgumentException: Invalid character found in method name. HTTP method names must be tokens
/var/log/messages.1:Nov 16 09:39:39 satellite1 server: java.lang.IllegalArgumentException: Invalid character found in method name. HTTP method names must be tokens
/var/log/messages.1:Nov 16 09:40:36 satellite1 server: java.lang.IllegalArgumentException: Invalid character found in method name. HTTP method names must be tokens
/var/log/messages.2:Nov  9 09:35:48 satellite1 server: java.lang.IllegalArgumentException: Invalid character found in method name. HTTP method names must be tokens
/var/log/messages.2:Nov  9 09:35:48 satellite1 server: java.lang.IllegalArgumentException: Invalid character found in method name. HTTP method names must be tokens
/var/log/messages.3:Nov  2 09:39:23 satellite1 server: java.lang.IllegalArgumentException: Invalid character found in method name. HTTP method names must be tokens
/var/log/messages.3:Nov  2 09:39:23 satellite1 server: java.lang.IllegalArgumentException: Invalid character found in method name. HTTP method names must be tokens
/var/log/messages.4:Oct 26 09:37:51 satellite1 server: java.lang.IllegalArgumentException: Invalid character found in method name. HTTP method names must be tokens
/var/log/messages.4:Oct 26 09:37:51 satellite1 server: java.lang.IllegalArgumentException: Invalid character found in method name. HTTP method names must be tokens

Is this a cron job?  The timing seems to variable.

Comment 2 Barnaby Court 2017-12-04 15:19:31 UTC
Moving the Subscription Management in case this call is coming from somewhere else within Satellite. This type of exception is the normal result of trying to make an HTTP call against an HTTPS endpoint in Tomcat. This bug should be used to figure out what is making this call as the error in the log is normal.

Comment 3 Ben 2017-12-07 11:39:24 UTC
Seen again this morning.  What other information can I give you other than the below:

Dec  7 09:42:13 satellite1 server: Dec 07, 2017 9:42:13 AM org.apache.coyote.http11.AbstractHttp11Processor process
Dec  7 09:42:13 satellite1 server: Note: further occurrences of HTTP header parsing errors will be logged at DEBUG level.
Dec  7 09:42:13 satellite1 server: java.lang.IllegalArgumentException: Invalid character found in method name. HTTP method names must be tokens
Dec  7 09:42:13 satellite1 server: at org.apache.coyote.http11.InternalInputBuffer.parseRequestLine(InternalInputBuffer.java:136)
Dec  7 09:42:13 satellite1 server: at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1000)
Dec  7 09:42:13 satellite1 server: at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:637)
Dec  7 09:42:13 satellite1 server: at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:316)
Dec  7 09:42:13 satellite1 server: at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1152)
Dec  7 09:42:13 satellite1 server: at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:622)
Dec  7 09:42:13 satellite1 server: at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
Dec  7 09:42:13 satellite1 server: at java.lang.Thread.run(Thread.java:748)
Dec  7 09:42:13 satellite1 server: Dec 07, 2017 9:42:13 AM org.apache.coyote.http11.AbstractHttp11Processor process
Dec  7 09:42:13 satellite1 server: Note: further occurrences of HTTP header parsing errors will be logged at DEBUG level.
Dec  7 09:42:13 satellite1 server: java.lang.IllegalArgumentException: Invalid character found in method name. HTTP method names must be tokens
Dec  7 09:42:13 satellite1 server: at org.apache.coyote.http11.InternalInputBuffer.parseRequestLine(InternalInputBuffer.java:136)
Dec  7 09:42:13 satellite1 server: at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1000)
Dec  7 09:42:13 satellite1 server: at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:637)
Dec  7 09:42:13 satellite1 server: at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:316)
Dec  7 09:42:13 satellite1 server: at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1152)
Dec  7 09:42:13 satellite1 server: at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:622)
Dec  7 09:42:13 satellite1 server: at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
Dec  7 09:42:13 satellite1 server: at java.lang.Thread.run(Thread.java:748)

Comment 4 Ben 2018-02-08 17:08:36 UTC
Any progress on this?  I'm still seeing it like clockwork every Thursday morning at ~09:42.

Comment 7 Brad Buckingham 2018-02-08 18:30:19 UTC
Hi Ben,

Based on information from a colleague, tomcat in 6.2 is listening on all interfaces; therefore, it is possible that something external to the box is trying to connect to port 8080 over http. 

Would it be possible to set a firewall rule to block that port externally?

Comment 8 Ben 2018-02-12 09:46:55 UTC
That's entirely possible.  I will look into it.

Comment 9 Bryan Kearney 2018-11-30 15:00:45 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Rich Jerrido or Bryan Kearney or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 10 Bryan Kearney 2019-02-07 12:03:51 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.