Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517217 - Multiple sessions of same user changes tabs in the RHGS Web Admin Dashboard
Summary: Multiple sessions of same user changes tabs in the RHGS Web Admin Dashboard
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-ui
Version: rhgs-3.3
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Nishanth Thomas
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-24 10:44 UTC by Vinayak Papnoi
Modified: 2018-12-07 11:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-07 11:16:28 UTC


Attachments (Terms of Use)

Description Vinayak Papnoi 2017-11-24 10:44:18 UTC
Description of problem:
=======================

If there are two or more sessions of the same user logged in from different systems, the RHGS Web Admin Dashboard changes tabs erratically.


Version-Release number of selected component (if applicable):
=============================================================

glusterfs-3.8.4-52.el7rhgs.x86_64
tendrl-grafana-plugins-1.5.4-5.el7rhgs.noarch
tendrl-ansible-1.5.4-1.el7rhgs.noarch
tendrl-selinux-1.5.3-2.el7rhgs.noarch
tendrl-node-agent-1.5.4-5.el7rhgs.noarch
tendrl-monitoring-integration-1.5.4-5.el7rhgs.noarch
tendrl-grafana-selinux-1.5.3-2.el7rhgs.noarch
tendrl-commons-1.5.4-4.el7rhgs.noarch
tendrl-api-1.5.4-2.el7rhgs.noarch
tendrl-api-httpd-1.5.4-2.el7rhgs.noarch
tendrl-notifier-1.5.4-3.el7rhgs.noarch
tendrl-ui-1.5.4-4.el7rhgs.noarch


How reproducible:
=================

1/1


Steps to Reproduce:
===================

1. Log in to the Web Admin from different systems simultaneously
2. From first session click on Clusters, let cluster page appear
3. From Second session click on Hosts, let hosts page appear
4. From first session click on Hosts

Result of step 4 is either: 

A. first session goes to cluster page inspite of selecting hosts
B. Second session goes to cluster page inspite of not doing anything


Actual results:
===============

Tabs switch automatically to "Clusters" even if "Hosts"/"Events" is clicked


Expected results:
=================

Should not switch tabs


Additional info:

Comment 2 Anup Nivargi 2017-11-24 11:50:21 UTC
The API creates access_tokens for each authentication request, so its possible to have multiple active sessions for a user from different systems. 
As long as the access_token is persisted for requesting resources, there should be no issue with the same user accessing the API from multiple systems.

Comment 3 Kanika Murarka 2017-11-24 12:42:45 UTC
@vpapnoi@redhat.com, This issue is not reproducible in the latest build.

Comment 4 Vinayak Papnoi 2017-12-11 05:52:21 UTC
I tried to reproduce this issue with latest build having 100+ GB root partition and 32 GB RAM on the tendrl server. Everything seems to work fine and the sessions aren't switching the tabs automatically.

Comment 6 Nishanth Thomas 2018-12-07 11:16:28 UTC
Looks like this issue is not reproducible as mentioned by the submitter. Closing the Bz


Note You need to log in before you can comment on or make changes to this bug.