Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517150 - Missing alerts for some bricks when volume stopped
Summary: Missing alerts for some bricks when volume stopped
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-notifier
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: gowtham
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-24 10:12 UTC by Filip Balák
Modified: 2018-01-12 09:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-12 09:57:51 UTC


Attachments (Terms of Use)
Hosts page (deleted)
2017-11-24 10:12 UTC, Filip Balák
no flags Details
/var/log/messages from gl2 host (deleted)
2017-11-24 10:14 UTC, Filip Balák
no flags Details

Description Filip Balák 2017-11-24 10:12:04 UTC
Created attachment 1358605 [details]
Hosts page

Description of problem:
I have stopped volume consisting of 6 hosts. Each host have 2 bricks. When I stopped the volume there are alerts regarding stopped bricks for all hosts except one: fbalak-usm1-gl2. In grafana are bricks from this host reported correctly as down.

Version-Release number of selected component (if applicable):
tendrl-ansible-1.5.4-1.el7rhgs.noarch
tendrl-ui-1.5.4-4.el7rhgs.noarch
tendrl-grafana-plugins-1.5.4-5.el7rhgs.noarch
tendrl-selinux-1.5.3-2.el7rhgs.noarch
tendrl-commons-1.5.4-4.el7rhgs.noarch
tendrl-api-1.5.4-2.el7rhgs.noarch
tendrl-api-httpd-1.5.4-2.el7rhgs.noarch
tendrl-monitoring-integration-1.5.4-5.el7rhgs.noarch
tendrl-grafana-selinux-1.5.3-2.el7rhgs.noarch
tendrl-node-agent-1.5.4-5.el7rhgs.noarch
tendrl-notifier-1.5.4-3.el7rhgs.noarch
tendrl-gluster-integration-1.5.4-4.el7rhgs.noarch
glusterfs-3.8.4-52.el7rhgs.x86_64

How reproducible:
50%

Steps to Reproduce:
1. Import cluster with disperse volume and 6 hosts, each host with 2 bricks.
2. Stop volume.
3. Wait for notifications.
4. Open Hosts page.

Actual results:
One of hosts doesn't generate any alerts.

Expected results:
All stopped bricks should notify user about their state.

Additional info:

Comment 1 Filip Balák 2017-11-24 10:14:31 UTC
Created attachment 1358609 [details]
/var/log/messages from gl2 host

Comment 2 Nishanth Thomas 2017-11-24 12:51:08 UTC
Not reproducible.
Need to wait for sync cycle to complete on all nodes.
Need clear reproducer to debug issues. Can re-consider if there is a reproducer.

Comment 3 gowtham 2018-01-10 10:18:43 UTC
Unable to reproduce this issue, alerts for all bricks are raised successfully

Comment 4 Filip Balák 2018-01-12 09:25:53 UTC
I was unable to reproduce this issue again neither. There was probably a problem with synchronisation but it occurs at random. Maybe we can close this issue. What do you think?

Comment 5 gowtham 2018-01-12 09:46:18 UTC
yes, we can close this issue

Comment 6 Filip Balák 2018-01-12 09:57:51 UTC
Ok --> CLOSED


Note You need to log in before you can comment on or make changes to this bug.