Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517141 - Installer crashes when 'lang' is set in kickstart file
Summary: Installer crashes when 'lang' is set in kickstart file
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 27
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-24 10:00 UTC by David Jansen
Modified: 2018-11-30 19:52 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-30 19:52:28 UTC


Attachments (Terms of Use)
anaconda.log (deleted)
2017-11-24 10:00 UTC, David Jansen
no flags Details
dnf.librepo.log (deleted)
2017-11-24 10:01 UTC, David Jansen
no flags Details
ifcfg.log (deleted)
2017-11-24 10:02 UTC, David Jansen
no flags Details
packaging.log (deleted)
2017-11-24 10:04 UTC, David Jansen
no flags Details
program.log (deleted)
2017-11-24 10:04 UTC, David Jansen
no flags Details
storage.log (deleted)
2017-11-24 10:05 UTC, David Jansen
no flags Details
storage.state (deleted)
2017-11-24 10:06 UTC, David Jansen
no flags Details
syslog (deleted)
2017-11-24 10:09 UTC, David Jansen
no flags Details
X.log (deleted)
2017-11-24 10:09 UTC, David Jansen
no flags Details
anaconda core dump (deleted)
2017-11-24 10:37 UTC, David Jansen
no flags Details
A minimal kickstart file that can reproduce the bug (deleted)
2017-11-27 11:16 UTC, David Jansen
no flags Details

Description David Jansen 2017-11-24 10:00:00 UTC
Created attachment 1358584 [details]
anaconda.log

Description of problem:

Installation using a kickstart file seems to work fine, except when the 'lang' setting is used to select a langage. It doesn't matter which language is selected (en_US, en_UK, en_US.UTF-8, nl_NL etc), in all cases, the installation crashes shortly after the main anaconda gui screen is shown (which then disappears replaced by a black screen plus mouse pointer cursor).
At that point, virtual console 1 shows that anaconda received signal 11 and dumped core.

PS: I have tried this with the kickstart file in various places, just to see if that makes a difference (on usb stick, over http, over nfs). Also tried in VNC (my preferred method) and on the local console, and tested this on 3 different computers.

Comment 1 David Jansen 2017-11-24 10:01:33 UTC
Created attachment 1358585 [details]
dnf.librepo.log

Comment 2 David Jansen 2017-11-24 10:02:01 UTC
Created attachment 1358586 [details]
ifcfg.log

Comment 3 David Jansen 2017-11-24 10:04:30 UTC
Created attachment 1358587 [details]
packaging.log

Comment 4 David Jansen 2017-11-24 10:04:53 UTC
Created attachment 1358588 [details]
program.log

Comment 5 David Jansen 2017-11-24 10:05:46 UTC
Created attachment 1358589 [details]
storage.log

Comment 6 David Jansen 2017-11-24 10:06:44 UTC
Created attachment 1358592 [details]
storage.state

Comment 7 David Jansen 2017-11-24 10:09:11 UTC
Created attachment 1358603 [details]
syslog

Comment 8 David Jansen 2017-11-24 10:09:42 UTC
Created attachment 1358604 [details]
X.log

Comment 9 David Jansen 2017-11-24 10:37:36 UTC
Created attachment 1358612 [details]
anaconda core dump

Comment 10 Jiri Konecny 2017-11-27 07:20:31 UTC
Hello,

Could you please provide us the kickstart file you are using. It looks to me like there is some specific settings which is causing the crash.

Thank you.

Comment 11 David Jansen 2017-11-27 11:16:06 UTC
Created attachment 1359428 [details]
A minimal kickstart file that can reproduce the bug

The logs from the actual install attempt had an more elaborate kickstart, but the attached version is sufficient to reproduce the crash for me.
When the 'lang' setting is removed, installation proceeds normally. Other valid versions for the lanugage give me the same results

Comment 12 Ben Cotton 2018-11-27 17:01:39 UTC
This message is a reminder that Fedora 27 is nearing its end of life.
On 2018-Nov-30  Fedora will stop maintaining and issuing updates for
Fedora 27. It is Fedora's policy to close all bug reports from releases
that are no longer maintained. At that time this bug will be closed as
EOL if it remains open with a Fedora  'version' of '27'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 27 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 13 Ben Cotton 2018-11-30 19:52:28 UTC
Fedora 27 changed to end-of-life (EOL) status on 2018-11-30. Fedora 27 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.