Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517130 - Email and SNMP trap messages sent with [tendrl-alert] in the subject line
Summary: Email and SNMP trap messages sent with [tendrl-alert] in the subject line
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-notifier
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Nishanth Thomas
QA Contact: Martin Kudlej
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-24 09:50 UTC by Sweta Anandpara
Modified: 2017-12-18 04:38 UTC (History)
5 users (show)

Fixed In Version: tendrl-notifier-1.5.4-6.el7rhgs.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 04:38:26 UTC


Attachments (Terms of Use)
screenshot of both email and snmp trap messages for alerts (deleted)
2017-11-24 10:13 UTC, Martin Bukatovic
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3478 normal SHIPPED_LIVE RHGS Web Administration packages 2017-12-18 09:34:49 UTC

Description Sweta Anandpara 2017-11-24 09:50:25 UTC
Description of problem:
======================
Configured email notification to my official redhat email ID. Stopped a brick and got it back up. The email alerts were received with the subject line mentioned below:

[Tendrl Alert] Brick Status, WARNING: status changed
[Tendrl Alert] Brick Status, INFO: status changed

There should not be a mention of 'Tendrl' if a customer/admin is using RHGS WA.


Version-Release number of selected component (if applicable):
==============================================================
tendrl-notifier-1.5.4-3.el7rhgs.noarch
tendrl-ansible-1.5.4-1.el7rhgs.noarch
tendrl-ui-1.5.4-4.el7rhgs.noarch
tendrl-monitoring-integration-1.5.4-5.el7rhgs.noarch
tendrl-grafana-selinux-1.5.3-2.el7rhgs.noarch
tendrl-commons-1.5.4-4.el7rhgs.noarch
tendrl-api-1.5.4-2.el7rhgs.noarch
tendrl-api-httpd-1.5.4-2.el7rhgs.noarch
tendrl-grafana-plugins-1.5.4-5.el7rhgs.noarch
tendrl-selinux-1.5.3-2.el7rhgs.noarch
tendrl-node-agent-1.5.4-5.el7rhgs.noarch



How reproducible:
================
Always


Steps to Reproduce:
====================
1. Have a RHGS WA server, import a 3-6 node cluster.
2. Configure email notification using the steps mentioned at https://github.com/Tendrl/documentation/wiki/Tendrl-release-v1.5.4-(install-guide)
3. Bring down a brick, or stop a volume
4. Check the email notification alert received at the destination

Actual results:
===============
[Tendrl Alert] Brick Status, WARNING: status changed
[Tendrl Alert] Brick Status, INFO: status changed


Expected results:
==================
[RHGS Web Admin alert] Brick Status, WARNING: status changed
[RHGS Web Admin Alert] Brick Status, INFO: status changed

Comment 4 Martin Bukatovic 2017-11-24 10:13:35 UTC
Created attachment 1358607 [details]
screenshot of both email and snmp trap messages for alerts

Comment 5 Martin Bukatovic 2017-11-24 10:16:38 UTC
The same title is used for SNMP trap messages as well. If we plan to fix it, we
need to make sure both SNMP and email alert channes are addressed.

Comment 8 Martin Kudlej 2017-12-04 15:07:11 UTC
I've tested this with these alerts:
[INFO] Peer Status: status changed
[WARNING] Brick Status: status changed
[WARNING] Cluster Health Status: status changed
[WARNING] Ec Min Bricks Up: status changed
[WARNING] Peer Reject: status changed
[WARNING] Peer Status: status changed
[WARNING] Peer Status: status changed  
[WARNING] Volume State: status changed
[WARNING] Volume Status: status changed

and there is no "tendrl" word in subject.
I've tested with
etcd-3.2.7-1.el7.x86_64
glusterfs-3.8.4-52.el7_4.x86_64
glusterfs-3.8.4-52.el7rhgs.x86_64
glusterfs-api-3.8.4-52.el7rhgs.x86_64
glusterfs-cli-3.8.4-52.el7rhgs.x86_64
glusterfs-client-xlators-3.8.4-52.el7_4.x86_64
glusterfs-client-xlators-3.8.4-52.el7rhgs.x86_64
glusterfs-events-3.8.4-52.el7rhgs.x86_64
glusterfs-fuse-3.8.4-52.el7_4.x86_64
glusterfs-fuse-3.8.4-52.el7rhgs.x86_64
glusterfs-geo-replication-3.8.4-52.el7rhgs.x86_64
glusterfs-libs-3.8.4-52.el7_4.x86_64
glusterfs-libs-3.8.4-52.el7rhgs.x86_64
glusterfs-rdma-3.8.4-52.el7rhgs.x86_64
glusterfs-server-3.8.4-52.el7rhgs.x86_64
gluster-nagios-addons-0.2.10-2.el7rhgs.x86_64
gluster-nagios-common-0.2.4-1.el7rhgs.noarch
libvirt-daemon-driver-storage-gluster-3.2.0-14.el7_4.4.x86_64
python-etcd-0.4.5-1.el7rhgs.noarch
python-gluster-3.8.4-52.el7rhgs.noarch
rubygem-etcd-0.3.0-1.el7rhgs.noarch
tendrl-ansible-1.5.4-2.el7rhgs.noarch
tendrl-api-1.5.4-4.el7rhgs.noarch
tendrl-api-httpd-1.5.4-4.el7rhgs.noarch
tendrl-collectd-selinux-1.5.4-1.el7rhgs.noarch
tendrl-commons-1.5.4-6.el7rhgs.noarch
tendrl-gluster-integration-1.5.4-8.el7rhgs.noarch
tendrl-grafana-plugins-1.5.4-11.el7rhgs.noarch
tendrl-grafana-selinux-1.5.4-1.el7rhgs.noarch
tendrl-monitoring-integration-1.5.4-11.el7rhgs.noarch
tendrl-node-agent-1.5.4-9.el7rhgs.noarch
tendrl-notifier-1.5.4-6.el7rhgs.noarch
tendrl-selinux-1.5.4-1.el7rhgs.noarch
tendrl-ui-1.5.4-5.el7rhgs.noarch
vdsm-gluster-4.17.33-1.2.el7rhgs.noarch

Comment 10 errata-xmlrpc 2017-12-18 04:38:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3478


Note You need to log in before you can comment on or make changes to this bug.