Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517116 - chronyd.service failed
Summary: chronyd.service failed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-node
Classification: oVirt
Component: General
Version: 4.2
Hardware: Unspecified
OS: Unspecified
unspecified
urgent vote
Target Milestone: ovirt-4.2.0
: 4.2
Assignee: Ryan Barry
QA Contact: Qin Yuan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-24 09:15 UTC by Qin Yuan
Modified: 2017-12-20 11:44 UTC (History)
13 users (show)

Fixed In Version: imgbased-1.0.3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 11:44:08 UTC
oVirt Team: Node
rule-engine: ovirt-4.2+
cshao: testing_plan_complete?
cshao: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 84713 master MERGED timeserver: don't move 'restrict' to chrony.conf either 2017-11-28 23:15:02 UTC
oVirt gerrit 84833 ovirt-4.2 MERGED timeserver: don't move 'restrict' to chrony.conf either 2017-11-28 23:15:14 UTC

Description Qin Yuan 2017-11-24 09:15:49 UTC
Description of problem:

chronyd.service status is failed after the first reboot:

[root@dhcp-10-21 ~]# systemctl status chronyd
● chronyd.service - NTP client/server
   Loaded: loaded (/usr/lib/systemd/system/chronyd.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Fri 2017-11-24 13:40:02 CST; 1h 14min ago
     Docs: man:chronyd(8)
           man:chrony.conf(5)
  Process: 957 ExecStart=/usr/sbin/chronyd $OPTIONS (code=exited, status=1/FAILURE)

Nov 24 13:40:01 localhost.localdomain systemd[1]: Starting NTP client/server...
Nov 24 13:40:02 localhost.localdomain chronyd[975]: chronyd version 3.1 starting (+CMDMON +NTP +REFCLOCK +RTC +PRIVDROP +SCFILTER +SECHASH +SIGND +ASYNCDNS +IPV6 +DEBUG)
Nov 24 13:40:02 localhost.localdomain chronyd[975]: Fatal error : Invalid command at line 3 in file /etc/chrony.conf
Nov 24 13:40:02 localhost.localdomain chronyd[957]: Invalid command at line 3 in file /etc/chrony.conf
Nov 24 13:40:02 localhost.localdomain systemd[1]: chronyd.service: control process exited, code=exited status=1
Nov 24 13:40:02 localhost.localdomain systemd[1]: Failed to start NTP client/server.
Nov 24 13:40:02 localhost.localdomain systemd[1]: Unit chronyd.service entered failed state.
Nov 24 13:40:02 localhost.localdomain systemd[1]: chronyd.service failed.


[root@dhcp-10-21 ~]# cat /etc/chrony.conf
# This file has been migrated or modified by imgbased

restrict ::1
driftfile /var/lib/chrony/drift
server 0.rhel.pool.ntp.org iburst
server 1.rhel.pool.ntp.org iburst
server 2.rhel.pool.ntp.org iburst
server 3.rhel.pool.ntp.org iburst
server clock02.util.phx2.redhat.com iburst
makestep 1.0 3
disable monitor
logdir /var/log/chrony
rtcsync 


Version-Release number of selected component (if applicable):
RHVH-4.2-20171123.0-RHVH-x86_64-dvd1.iso
imgbased-1.0.2-0.1.el7ev.noarch 


How reproducible:
100%


Steps to Reproduce:
1. Install RHVH-4.2-20171123.0-RHVH-x86_64-dvd1.iso
2. Enable the NIC, enable network time, and configure the ntp servers
3. Finish installation
4. Reboot and log into system
5. Check chronyd.service status using `systemctl status chronyd` 


Actual results:
1. After step5, the status of chronyd.service is failed 


Expected results:
1. After step5, the status of chronyd.service should be 'active (running)' 


Additional info:

Comment 1 Qin Yuan 2017-12-14 10:07:19 UTC
Versions:
RHVH-4.2-20171213.0-RHVH-x86_64-dvd1.iso
imgbased-1.0.5-0.1.el7ev.noarch

Steps:
The same as the steps described in comment #0

Results:
chronyd.service is active after installation.

The bug is fixed, change the status to VERIFIED.

Comment 2 Sandro Bonazzola 2017-12-20 11:44:08 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.