Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517108 - [ALL_LANG except zh_CN, ko_KR] Table headers getting truncated on compute->virtual machines-> disks -> new -> direct LUN page.
Summary: [ALL_LANG except zh_CN, ko_KR] Table headers getting truncated on compute->vi...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.0
Hardware: All
OS: Linux
medium
medium vote
Target Milestone: ovirt-4.2.1
: ---
Assignee: shani
QA Contact: Bhushan Barve
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-24 08:53 UTC by Bhushan Barve
Modified: 2018-02-12 11:47 UTC (History)
6 users (show)

Fixed In Version: ovirt-engine-4.2.0.1
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-02-12 11:47:18 UTC
oVirt Team: Storage
rule-engine: ovirt-4.2+
rule-engine: planning_ack+
gshereme: devel_ack+


Attachments (Terms of Use)
Table headers truncation (deleted)
2017-11-24 08:53 UTC, Bhushan Barve
no flags Details
ja_JP_truncation_4.2.0.2-0.1.el7 (deleted)
2017-12-19 10:39 UTC, Bhushan Barve
no flags Details
fr_FR_truncation_4.2.0.2-0.1.el7 (deleted)
2017-12-19 10:40 UTC, Bhushan Barve
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 84771 master MERGED webadmin: fix New Disk > Direct Lun header spacing 2017-11-29 14:09:51 UTC
oVirt gerrit 84938 master MERGED Revert "webadmin: fix New Disk > Direct Lun header spacing" 2017-11-30 12:55:13 UTC
oVirt gerrit 85079 master MERGED webadmin: Change view issues for SanStorage lists 2017-12-07 13:25:59 UTC
oVirt gerrit 85763 master MERGED webadmin: change iSCSI list table's titles 2017-12-27 13:03:47 UTC

Description Bhushan Barve 2017-11-24 08:53:00 UTC
Created attachment 1358565 [details]
Table headers truncation

Description of problem: For ja_JP locale, the menus on compute->virtual machines-> disks -> new -> direct LUN page are truncated. The issue is observed for menu items on LUN->Targets tab at the bottom. Please refer attached screenshot. This issue is observed for all locales except zh_CN and ko_KR. Please refer attached screenshot.


Version-Release number of selected component (if applicable):
4.2.0-0.5.master.el7

How reproducible:
always

Steps to Reproduce:
1. Login to admin portal with any of the above mentioned locales.
2. Go to compute->virtual machines-> disks -> new -> direct LUN page
3. At the bottom, click on LUN->Targets and observe the table headers.

Actual results:
Table headers are getting truncated.

Expected results:
Table headers should be visible properly.

Additional info:

Comment 1 Greg Sheremeta 2017-11-30 11:19:40 UTC
My patch did not work out, and Shani is already working on this. Reassigning and un-targeting.

Comment 2 Allon Mureinik 2017-12-14 10:14:43 UTC
The fix is included in the ovirt-engine-4.2.0.1 tag. Moving to ON_QA.

Comment 3 Bhushan Barve 2017-12-19 10:38:50 UTC
Checked with Version:4.2.0.2-0.1.el7
The mentioned issue still exists for table headers on compute->virtual machines-> disks -> new -> direct LUN page. Please refer attached screen-shots for reference. Moving it back to assigned.

Comment 4 Bhushan Barve 2017-12-19 10:39:55 UTC
Created attachment 1369886 [details]
ja_JP_truncation_4.2.0.2-0.1.el7

Comment 5 Bhushan Barve 2017-12-19 10:40:37 UTC
Created attachment 1369887 [details]
fr_FR_truncation_4.2.0.2-0.1.el7

Comment 6 Allon Mureinik 2018-01-24 14:36:18 UTC
Shani, all these patches are included in 4.2.1.
Do we need anything from the localization team, or are your patches all we need?
If so, please retarget to 4.2.1 and move to ON_QA.

Comment 7 shani 2018-01-24 18:03:41 UTC
The ellipsis (...) at the end of a too long table's header and the added tooltips supposed to solve the issue, so it does not depend on the localization team.

Comment 8 Bhushan Barve 2018-02-01 09:32:29 UTC
Checked with 4.2.1.3-0.1.el7
Looks fine now for all the mentioned locales.
Marking it as verified.

Comment 9 Sandro Bonazzola 2018-02-12 11:47:18 UTC
This bugzilla is included in oVirt 4.2.1 release, published on Feb 12th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.1 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.