Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517089 - While performing replace-brick,incorrect heal fail info is reflected in web admin dashboard
Summary: While performing replace-brick,incorrect heal fail info is reflected in web a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-monitoring-integration
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
: ---
Assignee: Shubhendu Tripathi
QA Contact: Bala Konda Reddy M
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-24 07:40 UTC by Manisha Saini
Modified: 2017-12-18 04:38 UTC (History)
14 users (show)

Fixed In Version: tendrl-monitoring-integration-1.5.4-11.el7rhgs.noarch tendrl-gluster-integration-1.5.4-6.el7rhgs.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 04:38:26 UTC


Attachments (Terms of Use)
Screenshot (deleted)
2017-11-24 07:42 UTC, Manisha Saini
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3478 normal SHIPPED_LIVE RHGS Web Administration packages 2017-12-18 09:34:49 UTC

Description Manisha Saini 2017-11-24 07:40:52 UTC
Description of problem:
While performing replace-brick,incorrect heal fail info is reflected in web admin dashboard

Version-Release number of selected component (if applicable):
# rpm -qa|egrep "tendrl|gluster|kernel"
libvirt-daemon-driver-storage-gluster-3.2.0-14.el7_4.3.x86_64
samba-vfs-glusterfs-4.6.3-6.el7rhgs.x86_64
glusterfs-fuse-3.8.4-52.el7rhgs.x86_64
python-gluster-3.8.4-52.el7rhgs.noarch
gluster-nagios-common-0.2.4-1.el7rhgs.noarch
kernel-tools-libs-3.10.0-693.5.2.el7.x86_64
glusterfs-libs-3.8.4-52.el7rhgs.x86_64
tendrl-node-agent-1.5.4-5.el7rhgs.noarch
vdsm-gluster-4.17.33-1.2.el7rhgs.noarch
gluster-nagios-addons-0.2.9-1.el7rhgs.x86_64
nfs-ganesha-gluster-2.4.4-17.el7rhgs.x86_64
glusterfs-debuginfo-3.8.4-51.el7rhgs.x86_64
glusterfs-3.8.4-52.el7rhgs.x86_64
glusterfs-cli-3.8.4-52.el7rhgs.x86_64
glusterfs-ganesha-3.8.4-52.el7rhgs.x86_64
tendrl-selinux-1.5.3-2.el7rhgs.noarch
tendrl-commons-1.5.4-4.el7rhgs.noarch
glusterfs-events-3.8.4-52.el7rhgs.x86_64
tendrl-gluster-integration-1.5.4-4.el7rhgs.noarch
kernel-tools-3.10.0-693.5.2.el7.x86_64
kernel-3.10.0-693.5.2.el7.x86_64
glusterfs-client-xlators-3.8.4-52.el7rhgs.x86_64
glusterfs-server-3.8.4-52.el7rhgs.x86_64
glusterfs-rdma-3.8.4-52.el7rhgs.x86_64
tendrl-collectd-selinux-1.5.3-2.el7rhgs.noarch
abrt-addon-kerneloops-2.1.11-48.el7.x86_64
kernel-3.10.0-693.2.2.el7.x86_64
glusterfs-geo-replication-3.8.4-52.el7rhgs.x86_64
kernel-3.10.0-693.2.1.el7.x86_64
glusterfs-api-3.8.4-52.el7rhgs.x86_64



How reproducible:
2/2

Steps to Reproduce:
Steps to Reproduce:
1.Create 2 volumes 4*3 Distributed-Replicate volume
2.Perform replace brick operation (replace 1 brick) on one volume 
# gluster v replace-brick ganeshavol1 dhcp42-127.lab.eng.blr.redhat.com:/gluster/brick3/1 dhcp42-127.lab.eng.blr.redhat.com:/gluster/brick6/1test commit force
3.Check web admin dashboard 


Actual results:
On web admin dashboard,it reflects some files in heal failed on Grafana dashboard after peforming replace-brick


Expected results:
It should not reflect any heal failed files on web admin dashboard after performing replace-brick

Additional info:

Comment 2 Manisha Saini 2017-11-24 07:42:01 UTC
Created attachment 1358523 [details]
Screenshot

Comment 3 Manisha Saini 2017-11-24 07:46:24 UTC
After waiting for around 25-30 mins,It shows correct status in heal web admin (as 0 heal files)

Comment 6 nchilaka 2017-11-27 09:03:40 UTC
statistics command is not supported downstream.
Also, refer to 1517072 - don't show "healed" and "heal-failed" entries in dashboard as they are deprecated 

so kindly stop fetching details from "heal statistics " command

Comment 7 Manisha Saini 2017-11-27 09:06:08 UTC
As per comment #6,Removing the needinfo

Comment 23 Bala Konda Reddy M 2017-12-06 14:20:39 UTC
Verified with
tendrl-gluster-integration-1.5.4-8.el7rhgs.noarch
tendrl-monitoring-integration-1.5.4-11.el7rhgs.noarch

Followed the steps mentioned in the bug and didn't see any heal failed on the heal panel on grafana dashboard. 

As the bug is wrt incorrect heal info.

I am marking it as verified as I didn't see any of the heal fail info on the dashboard

Comment 25 errata-xmlrpc 2017-12-18 04:38:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3478


Note You need to log in before you can comment on or make changes to this bug.