Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517080 - After performing replace-brick,the removed brick is still being reflected in web admin dashboard
Summary: After performing replace-brick,the removed brick is still being reflected in ...
Keywords:
Status: CLOSED DUPLICATE of bug 1516789
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-ui
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: gowtham
QA Contact: Rochelle
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-24 07:13 UTC by Manisha Saini
Modified: 2017-12-15 12:59 UTC (History)
6 users (show)

Fixed In Version: tendrl-ui-1.5.4-4.el7rhgs.noarch tendrl-gluster-integration-1.5.4-6.el7rhgs.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-28 11:06:38 UTC


Attachments (Terms of Use)
Screenshot (deleted)
2017-11-24 07:17 UTC, Manisha Saini
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3478 normal SHIPPED_LIVE RHGS Web Administration packages 2017-12-18 09:34:49 UTC
Red Hat Bugzilla 1515789 None None None Never

Internal Links: 1515789

Description Manisha Saini 2017-11-24 07:13:09 UTC
Description of problem:
After performing replace-brick,the removed brick is still being reflected in web admin dashboard

Version-Release number of selected component (if applicable):
# rpm -qa|egrep "tendrl|gluster|kernel"
libvirt-daemon-driver-storage-gluster-3.2.0-14.el7_4.3.x86_64
samba-vfs-glusterfs-4.6.3-6.el7rhgs.x86_64
glusterfs-fuse-3.8.4-52.el7rhgs.x86_64
python-gluster-3.8.4-52.el7rhgs.noarch
gluster-nagios-common-0.2.4-1.el7rhgs.noarch
kernel-tools-libs-3.10.0-693.5.2.el7.x86_64
glusterfs-libs-3.8.4-52.el7rhgs.x86_64
tendrl-node-agent-1.5.4-5.el7rhgs.noarch
vdsm-gluster-4.17.33-1.2.el7rhgs.noarch
gluster-nagios-addons-0.2.9-1.el7rhgs.x86_64
nfs-ganesha-gluster-2.4.4-17.el7rhgs.x86_64
glusterfs-debuginfo-3.8.4-51.el7rhgs.x86_64
glusterfs-3.8.4-52.el7rhgs.x86_64
glusterfs-cli-3.8.4-52.el7rhgs.x86_64
glusterfs-ganesha-3.8.4-52.el7rhgs.x86_64
tendrl-selinux-1.5.3-2.el7rhgs.noarch
tendrl-commons-1.5.4-4.el7rhgs.noarch
glusterfs-events-3.8.4-52.el7rhgs.x86_64
tendrl-gluster-integration-1.5.4-4.el7rhgs.noarch
kernel-tools-3.10.0-693.5.2.el7.x86_64
kernel-3.10.0-693.5.2.el7.x86_64
glusterfs-client-xlators-3.8.4-52.el7rhgs.x86_64
glusterfs-server-3.8.4-52.el7rhgs.x86_64
glusterfs-rdma-3.8.4-52.el7rhgs.x86_64
tendrl-collectd-selinux-1.5.3-2.el7rhgs.noarch
abrt-addon-kerneloops-2.1.11-48.el7.x86_64
kernel-3.10.0-693.2.2.el7.x86_64
glusterfs-geo-replication-3.8.4-52.el7rhgs.x86_64
kernel-3.10.0-693.2.1.el7.x86_64
glusterfs-api-3.8.4-52.el7rhgs.x86_64


How reproducible:


Steps to Reproduce:
1.Create 2 volumes 4*3 Distributed-Replicate volume
2.Perform replace brick operation (replace 1 brick) on one volume 
# gluster v replace-brick ganeshavol1 dhcp42-127.lab.eng.blr.redhat.com:/gluster/brick3/1 dhcp42-127.lab.eng.blr.redhat.com:/gluster/brick6/1test commit force
3.Check web admin dashboard 

Actual results:
web admin dashboard reflects the new brick along with removed brick.Status is not updated on web admin dashboard


Expected results:
Web admin dashboard should not show the removed brick in brick status


Additional info:

On dashboard it reflects 13 bricks.But actual bricks for the volume is 12


# gluster v info ganeshavol1
 
Volume Name: ganeshavol1
Type: Distributed-Replicate
Volume ID: 55c300dd-fecf-48ba-a57f-e472418f9b6e
Status: Started
Snapshot Count: 0
Number of Bricks: 4 x 3 = 12
Transport-type: tcp
Bricks:
Brick1: dhcp42-125.lab.eng.blr.redhat.com:/gluster/brick1/1
Brick2: dhcp42-127.lab.eng.blr.redhat.com:/gluster/brick1/1
Brick3: dhcp42-129.lab.eng.blr.redhat.com:/gluster/brick1/1
Brick4: dhcp42-119.lab.eng.blr.redhat.com:/gluster/brick1/1
Brick5: dhcp42-125.lab.eng.blr.redhat.com:/gluster/brick2/1
Brick6: dhcp42-127.lab.eng.blr.redhat.com:/gluster/brick2/1
Brick7: dhcp42-129.lab.eng.blr.redhat.com:/gluster/brick2/1
Brick8: dhcp42-119.lab.eng.blr.redhat.com:/gluster/brick2/1
Brick9: dhcp42-125.lab.eng.blr.redhat.com:/gluster/brick3/1
Brick10: dhcp42-127.lab.eng.blr.redhat.com:/gluster/brick6/1test
Brick11: dhcp42-129.lab.eng.blr.redhat.com:/gluster/brick3/1
Brick12: dhcp42-119.lab.eng.blr.redhat.com:/gluster/brick3/1
Options Reconfigured:
diagnostics.count-fop-hits: on
diagnostics.latency-measurement: on
transport.address-family: inet
nfs.disable: on
nfs-ganesha: disable
cluster.enable-shared-storage: disable

Comment 2 Manisha Saini 2017-11-24 07:17:05 UTC
Created attachment 1358506 [details]
Screenshot

Comment 4 Martin Kudlej 2017-11-24 07:44:36 UTC

*** This bug has been marked as a duplicate of bug 1515789 ***

Comment 7 Daniel Horák 2017-11-28 11:06:38 UTC
This is duplicate of Bug 1516789 (Martin probably mistype the Bug number as it is strangely similar).

*** This bug has been marked as a duplicate of bug 1516789 ***


Note You need to log in before you can comment on or make changes to this bug.