Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1517020 - [RFE]Assign primary private ip address to amazon instance
Summary: [RFE]Assign primary private ip address to amazon instance
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.8.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: GA
: cfme-future
Assignee: Loic Avenel
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-24 00:34 UTC by tachoi
Modified: 2019-01-22 21:40 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-22 21:40:49 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description tachoi 2017-11-24 00:34:26 UTC
Description of problem:
CF 4.2.3
Customer is trying to use AWS EC2 serivce from their service catalog ordering.
Most of provisioning feature is working well however one request has been raised.
Customer is having direct connect with AWS cloud so while their EC2 is being spinning-up, they want to provide their private ip address rather than Amazon private ip address.
Technically, customer still can connect EC2 instance via Amazon private ip address though, they want EC2 instance has their ip address range which can be provided via their on premise IPMS(IP management system)
With this fuction, they can manage all VMs in various providers(VMware,AWS etc) with consistent policy and manner.
Had a review the doc and tried same way with VMware provision but it looks like "ip_addr" option is not being used during instance provisions for AWS

Version-Release number of selected component (if applicable):
CF 4.2.3
AWS with direct connect

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:
"ip_addr" option couldn't update AWS EC2 instance private address

Expected results:
"ip_addr" option can update AWS EC2 instance private address

Additional info:

Comment 8 Josh Carter 2019-01-22 21:40:49 UTC
Thank you for your interest in CloudForms. We have evaluated this feature request, and we do not expect this to be implemented in product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact CloudForms Product Management .. Thank you.

If you have any concerns about this, please let us know.

Thanks and regards!”


Note You need to log in before you can comment on or make changes to this bug.