Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516917 - [UI] IE11: when a lot of notifications occur, they are scattered all over the screen
Summary: [UI] IE11: when a lot of notifications occur, they are scattered all over the...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
low
low vote
Target Milestone: ovirt-4.2.0
: ---
Assignee: Alexander Wels
QA Contact: Pavel Novotny
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-23 14:56 UTC by Greg Sheremeta
Modified: 2017-12-20 10:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 10:43:00 UTC
oVirt Team: UX
rule-engine: ovirt-4.2+
pnovotny: testing_plan_complete-


Attachments (Terms of Use)
notifications covering the screen in IE11 [Edge mode] (deleted)
2017-11-23 14:57 UTC, Greg Sheremeta
no flags Details
screen: IE11 - notifications stacked vertically (deleted)
2017-12-19 17:42 UTC, Pavel Novotny
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 84827 master MERGED webadmin: ie11 display of notifications 2017-11-28 21:16:39 UTC

Description Greg Sheremeta 2017-11-23 14:56:25 UTC
Description of problem:
[UI] IE11: when a lot of notifications occur, they are scattered all over the screen

Version-Release number of selected component (if applicable):
master 4.2 (173fe83)

How reproducible:
?

Steps to Reproduce:
1. do some operations at once that will cause many notifications
[in my test, i have 50 fakevdsm hosts whose statuses are changing]

Actual results:
see screenshot -- notifications everywhere

Expected results:
the notifications should be all on the right, stacked vertically. And we may want to limit the number that are shown -- maybe, show 10 and "Please see event log for the rest" or a similar message.

Comment 1 Greg Sheremeta 2017-11-23 14:57:44 UTC
Created attachment 1358261 [details]
notifications covering the screen in IE11 [Edge mode]

Comment 2 Pavel Novotny 2017-12-19 17:41:00 UTC
Verified in
ovirt-engine-4.2.0.2-0.1.el7.noarch
ovirt-engine-webadmin-portal-4.2.0.2-0.1.el7.noarch

I verified by generating 100 notifications at the same time (via a DB hack).
The notifications are now stacked vertically also in IE 11 (Windows 8.1).
See the attached screenshot.

One minor downside for IE 11 is that user cannot scroll the page, while Chromium offers the vertical scrollbar.
But on the other hand, if each notification lasts for 5 seconds or so, then the user has no chance to read them all if there is like 20 or more of them at the same time.

Comment 3 Pavel Novotny 2017-12-19 17:42:01 UTC
Created attachment 1370127 [details]
screen: IE11 - notifications stacked vertically

Comment 4 Sandro Bonazzola 2017-12-20 10:43:00 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.