Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516907 - Editing VM properties task hangs forever. The only way out is remove job_id from postgres and engine restart
Summary: Editing VM properties task hangs forever. The only way out is remove job_id f...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.1.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ovirt-4.2.1
: ---
Assignee: Eyal Shenitzky
QA Contact: Yosi Ben Shimon
URL:
Whiteboard:
Depends On: 1492473
Blocks: 1528950
TreeView+ depends on / blocked
 
Reported: 2017-11-23 14:35 UTC by Gajanan
Modified: 2018-05-15 17:47 UTC (History)
14 users (show)

Fixed In Version: ovirt-engine-4.2.1.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1492473
: 1528950 (view as bug list)
Environment:
Last Closed: 2018-05-15 17:46:12 UTC
oVirt Team: Storage


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 84893 None None None 2017-12-25 09:54:21 UTC
oVirt gerrit 85626 ovirt-engine-4.1 MERGED core: Change lock scope to 'Command' in UpdateVMCommand 2017-12-21 09:25:44 UTC
Red Hat Knowledge Base (Solution) 3245171 None None None 2017-11-23 14:44:58 UTC
Red Hat Product Errata RHEA-2018:1488 None None None 2018-05-15 17:47:48 UTC

Description Gajanan 2017-11-23 14:35:48 UTC
+++ This bug was initially created as a clone of Bug #1492473 +++

Description of problem:
Setting of High Availability properties cause Tasks window to hang up

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.create VM, run , open 'High Available' tab, check High Availability box and choose nfs_2 from drop down list, ok brings a message that VM must be restarted.
2.poweroff the VM. Open the 'High Available' again. change the nfs_2 to nfs_1. ok
3.run VM 

Actual results:
In tasks tab (right upper corner)  you see the 'Editing VM properties' task in  'Finalizing' state which just hangs up and never ends. the only way is remove job_id from job table of postgres , and then restart engine

Expected results:
VM is started with new High Available settings

Additional info:
sometimes you have to repeate the scenario (open High Availability tab/run VM) twice to reproduce

--- Additional comment from Polina on 2017-09-17 11:38 EDT ---



--- Additional comment from Tomas Jelinek on 2017-09-18 02:39:37 EDT ---

please always attach engine and vdsm logs to bug reports

--- Additional comment from Polina on 2017-10-02 10:11 EDT ---



--- Additional comment from Tomas Jelinek on 2017-10-06 07:01:57 EDT ---

There are simpler steps to reproduce:
- create VM
- edit VM and set it as HA with lease on SD1
- save
- (quickly) edit again and change the lease to SD2

The problem looks like a regression from https://gerrit.ovirt.org/#/c/72120/
Before that patch, the vm lease commands were sync so the VM was locked while running this commands.

Since that patch the lease commands are async and take a while to run, but the VM is for some reason not locked. And since the VM is not locked, it is possible to run an another edit (even of the lease) on it. This race causes the jobs not being finished properly.

Moving to storage for further investigation.

--- Additional comment from Polina on 2017-11-21 03:49:10 EST ---

the negative effect of the bug even worse, since after this the leases in HA tab disappear. impossible to choose HA lease.

Comment 3 Yosi Ben Shimon 2018-01-14 15:12:12 UTC
Tested and when running the next scenario:
- create VM
- edit VM and set it as HA with lease on SD1
- save
- (quickly) edit again and change the lease to SD2


i get a message:
"Error while executing action: 

<name of vm>:
Cannot edit VM. VM is being updated."

Tested using:
ovirt-engine-4.2.1.1-0.1.el7.noarch

Moving to VERIFIED

Comment 7 errata-xmlrpc 2018-05-15 17:46:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488


Note You need to log in before you can comment on or make changes to this bug.