Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516865 - On grafana dashboard, rebalance information is inconsistent
Summary: On grafana dashboard, rebalance information is inconsistent
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-monitoring-integration
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Nishanth Thomas
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-23 13:01 UTC by Bala Konda Reddy M
Modified: 2017-12-18 04:37 UTC (History)
6 users (show)

Fixed In Version: tendrl-monitoring-integration-1.5.4-8.el7rhgs.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 04:37:58 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3478 normal SHIPPED_LIVE RHGS Web Administration packages 2017-12-18 09:34:49 UTC
Github https://github.com/Tendrl monitoring-integration issues 291 None None None 2017-11-23 14:45:46 UTC

Description Bala Konda Reddy M 2017-11-23 13:01:27 UTC
Description of problem:
Imported cluster successfully and created few volumes. On one volume perfored add-brick, then started rebalance. On the Volume dashboard, in Rebalance status widget the status is started. In rebalance widget, The number of rebalance files, MB Size, skipped and failures are fluctuating for every 10 seconds. the data in the widget is misleading.  



Version-Release number of selected component (if applicable):
tendrl-ui-1.5.4-4.el7rhgs.noarch

How reproducible:
2/2

Steps to Reproduce:
1. Created a volume 2*3 volume
2. Performed add-brick on this volume and it succeeded.
3. Started the rebalance 

Actual results:
The rebalanced files, MB Size, skipped, Failures are fluctuating. The size of rebalanced files is showing in MB as it in GB 

Expected results:
The details should be aggregrate and should not fluctuate.

Additional info:

Comment 5 Bala Konda Reddy M 2017-11-29 11:49:53 UTC
Build: tendrl-monitoring-integration-1.5.4-8.el7rhgs.noarch

On an imported cluster.
Created a dist-rep volume and mounted it, while the io's are going on performed add-brick operation. Started rebalance and it showed up in the grafana dashboard as in-progress. Once the rebalance is done, it showed completed. The information is not fluctuating and consistent.

Hence marking it as verified.

Comment 7 errata-xmlrpc 2017-12-18 04:37:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3478


Note You need to log in before you can comment on or make changes to this bug.