Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516857 - [debuginfo-install]: No message when a package does not exist
Summary: [debuginfo-install]: No message when a package does not exist
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-23 12:54 UTC by Christian Stadelmann
Modified: 2018-06-28 08:36 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-28 08:36:37 UTC


Attachments (Terms of Use)

Description Christian Stadelmann 2017-11-23 12:54:11 UTC
Description of problem:
When running `dnf debuginfo-install [packagename]` for a package which does not exist, there is no warning or error.

Version-Release number of selected component (if applicable):
dnf-plugins-core-2.1.5-1.fc27.noarch

How reproducible:
always

Steps to Reproduce:
1. run `dnf debuginfo-install foo` or `dnf debuginfo-install xorg-x11-server-xwayland`
2. watch output
3.

Actual results:
No warning. DNF exits with "nothing to do" message.

Expected results:
Give a warning that the package does not exist. This is the default behavior without debuginfo-install, i.e. `dnf install foo` or `dnf install xorg-x11-server-xwayland`.

Additional info:
Fixing this issue would help detecting typos such as "xorg-x11-server-xwayland" instead of "xorg-x11-server-Xwayland".

Comment 1 Jaroslav Mracek 2017-12-08 13:31:36 UTC
I created a patch that should solve the issue (https://github.com/rpm-software-management/dnf-plugins-core/pull/243).

Comment 2 Jaroslav Mracek 2018-06-28 08:36:37 UTC
The issue is solved by dnf-plugins-core-3.0.1-1 that was released into rawhide.


Note You need to log in before you can comment on or make changes to this bug.