Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516850 - httpd24 should provide httpd
Summary: httpd24 should provide httpd
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Software Collections
Classification: Red Hat
Component: httpd24
Version: httpd24
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: alpha
: 3.1
Assignee: Luboš Uhliarik
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-23 12:45 UTC by Andrei Stepanov
Modified: 2017-11-24 08:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-24 08:43:58 UTC


Attachments (Terms of Use)

Description Andrei Stepanov 2017-11-23 12:45:29 UTC
I am trying to use httpd24 image for running WSGI python application (pagure).

Container https://access.redhat.com/containers/#/registry.access.redhat.com/rhscl/httpd-24-rhel7   has httpd from RHSCL.

When I install "pagure" it ignores installed "httpd24" and tries to install "httpd".

Version-Release number of selected component (if applicable): 2.4-43
How reproducible: always.

~ rpm -qR pagure
/bin/bash
/usr/bin/env
config(pagure) = 2.3.4-1.el7
gitolite3
mod_wsgi
py-bcrypt
python(abi) = 2.7
python-alembic
python-arrow
python-binaryornot
python-bleach
python-blinker
python-chardet
python-cryptography
python-docutils
python-enum34
python-fedora
python-flask
python-flask-multistatic
python-flask-wtf
python-markdown
python-munch
python-openid
python-openid-cla
python-openid-teams
python-psutil
python-pygit2 >= 0.20.1
python-pygments
python-redis
python-sqlalchemy > 0.8
python-straight-plugin
python-wtforms
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1


on system with present httpd24:

Installing:
 pagure                 noarch 2.3.4-1.el7      rhit_epel-7_rpms          6.5 M
Installing for dependencies:
 fipscheck              x86_64 1.4.1-6.el7      rhel-7-server-rpms         21 k
 fipscheck-lib          x86_64 1.4.1-6.el7      rhel-7-server-rpms         11 k
 freetype               x86_64 2.4.11-15.el7    rhel-7-server-rpms        392 k
 git                    x86_64 1.8.3.1-12.el7_4 rhel-7-server-rpms        4.4 M
 gitolite3              noarch 1:3.6.7-3.el7    rhit_epel-7_rpms          127 k
 gnutls                 x86_64 3.3.26-9.el7     rhel-7-server-rpms        677 k
 http-parser            x86_64 2.7.1-5.el7_4    rhel-7-server-rpms         28 k
 httpd                  x86_64 2.4.6-67.el7_4.6 rhel-7-server-rpms        1.2 M

Comment 2 Joe Orton 2017-11-23 16:54:24 UTC

*** This bug has been marked as a duplicate of bug 1516830 ***

Comment 3 Andrei Stepanov 2017-11-23 17:29:14 UTC
These are two different bugs:

1. httpd24 from rhscl and httpd cannot be installed together in container. On stable system I can do this. I saw your answer: "this is not supported". Any explanation why this is not supported?

2. httpd24 should provide "httpd" in Provides. If system has httpd24, why do packages try to install httpd?

Comment 4 Luboš Uhliarik 2017-11-24 07:54:05 UTC
Hi Andrei,

1) you have already answered your question in #1516830

2) because httpd24 is part of RHSCL [0], not a standard RHEL package. httpd24-httpd should provide "webserver", but we removed it because of this bug[1].

Please, go through attached links, you may find answers for your questions there.

[0] https://access.redhat.com/documentation/en-US/Red_Hat_Developer_Toolset/1/html/Software_Collections_Guide/

[1] http://bugzilla.redhat.com/show_bug.cgi?id=1042877


Note You need to log in before you can comment on or make changes to this bug.