Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516847 - Delay in transition of states with respect to Geo-replication on the Grafana dashboard
Summary: Delay in transition of states with respect to Geo-replication on the Grafana ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-ui
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Nishanth Thomas
QA Contact: Rochelle
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-23 12:42 UTC by Rochelle
Modified: 2017-12-18 04:37 UTC (History)
4 users (show)

Fixed In Version: tendrl-gluster-integration-1.5.4-6.el7rhgs.noarch tendrl-monitoring-integration-1.5.4-8.el7rhgs.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 04:37:58 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3478 normal SHIPPED_LIVE RHGS Web Administration packages 2017-12-18 09:34:49 UTC

Description Rochelle 2017-11-23 12:42:42 UTC
Description of problem:
=======================
Geo-replication states are showing up as expected but after a delay of about 20 minutes.

As a side note : when moving the geo-replication status from started to paused, it moves to "partial" for a while and then to "paused".
As discussed, when the session is moved from started to paused, some bricks go offline and "partial" in that case is correct but since the session is just paused, which could be misleading and since there's 20 min + delay, the user might not wait for the state to move to "paused"


Version-Release number of selected component (if applicable):
=============================================================
tendrl-notifier-1.5.4-3.el7rhgs.noarch
tendrl-ui-1.5.4-4.el7rhgs.noarch
tendrl-monitoring-integration-1.5.4-5.el7rhgs.noarch
tendrl-grafana-selinux-1.5.3-2.el7rhgs.noarch
tendrl-commons-1.5.4-4.el7rhgs.noarch
tendrl-api-1.5.4-2.el7rhgs.noarch
tendrl-api-httpd-1.5.4-2.el7rhgs.noarch
tendrl-grafana-plugins-1.5.4-5.el7rhgs.noarch
tendrl-ansible-1.5.4-1.el7rhgs.noarch
tendrl-selinux-1.5.3-2.el7rhgs.noarch
tendrl-node-agent-1.5.4-5.el7rhgs.noarch

How reproducible:
==================
Always


Actual results:
===============
There is a 20 min + delay between geo-replication states seen on the Grafana dashboard


Expected results:
=================
There shouldn't be such a long delay

Comment 3 Rohan Kanade 2017-11-23 15:23:04 UTC
We have improvements in this area in the next build. I request we measure the transition delay on the upcoming build.

Comment 8 errata-xmlrpc 2017-12-18 04:37:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3478


Note You need to log in before you can comment on or make changes to this bug.