Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516841 - Filters are not working in Service > Requests
Summary: Filters are not working in Service > Requests
Keywords:
Status: CLOSED DUPLICATE of bug 1512719
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: GA
: cfme-future
Assignee: Hilda Stastna
QA Contact: Dave Johnson
URL:
Whiteboard: testathon
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-23 12:31 UTC by Andrés Valero
Modified: 2017-12-08 15:00 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-07 15:04:42 UTC
Category: Bug
Cloudforms Team: CFME Core


Attachments (Terms of Use)
Error screen (deleted)
2017-11-23 12:31 UTC, Andrés Valero
no flags Details
How to reproduce error (deleted)
2017-12-01 10:14 UTC, Andrés Valero
no flags Details
DB file, key and GUID (deleted)
2017-12-04 15:14 UTC, Andrés Valero
no flags Details

Description Andrés Valero 2017-11-23 12:31:15 UTC
Created attachment 1358179 [details]
Error screen

Description of problem:
Filters are not working in Service > Requests 

Version-Release number of selected component (if applicable):
5.9.0.10

How reproducible:


Steps to Reproduce:
1. Select Service > Requests
2. Select any kind of filter in 
3. Select or unselect any kind of filter
4. Click apply

Actual results:
An error screen shows up

Expected results:
Filtering information

Additional info:
Tested on MacOs and Linux (Chrome and Firefox)

Comment 3 Hilda Stastna 2017-11-30 16:53:44 UTC
Hi Andres,

I cannot reproduce the bug. Could I ask you for the appliance or could you provide more info/attachments about steps to reproduce? I am not sure if I understand especially steps 2 and 3. Thank you!

Comment 4 Andrés Valero 2017-12-01 10:14:01 UTC
Created attachment 1361488 [details]
How to reproduce error

The first bug was reported working with cfme 5.9.0.9 today I´ve reproduced it again with cfme 5.9.0.11, I have the appliance running on GCE and you can access it on https://35.197.202.33/, user: admin, password: smartvm. It will be running till 15:30 Spanish time, then I will shut it down.

Comment 5 Andrés Valero 2017-12-01 10:16:30 UTC
I hope with this extra info I´ve added you will we able to reproduce the bug, if not do not hesitate in contacting me again.

Thanks !!

Comment 6 Hilda Stastna 2017-12-04 10:38:03 UTC
Andres, thank you for the great and detailed info about reproducing this bug. I was able to reproduce the bug only on your appliance, not in 5.9. and also not in master. Do you have the DB for your appliance? Maybe it will help.

Comment 7 Andrés Valero 2017-12-04 15:14:28 UTC
Created attachment 1362713 [details]
DB file, key and GUID

Inside tar.gz file, there are a .db file and a v2key and GUID (v2key and GUID files are with the whole path) from my 5.9.0.11 appliance. I had this same error in cfme 5.9.0.9 two weeks ago running in ravello environment in Madrid test-a-thon (I did not deploy this appliance) and as you could see I had the same problem in 5.9.0.11 running in GCE so I don´t think it´s something related with my appliance or configuration.
Hope this info helps.

Comment 8 Andrés Valero 2017-12-04 15:16:42 UTC
The region is 0, I forgot to comment.

Comment 9 Hilda Stastna 2017-12-07 15:04:42 UTC
Andres,

I have checked your DB and I was not reproduce the bug again. I have found that in 5.9.0.11 the bug was present but not in 5.9.0.12 so this is why I cannot reproduce the bug in any way. The bug was already fixed in https://github.com/ManageIQ/manageiq-ui-classic/pull/2830
And I am closing this bug as a dup.

*** This bug has been marked as a duplicate of bug 1512719 ***


Note You need to log in before you can comment on or make changes to this bug.